Same code but different values of simulation from two computers

I have a laptop and a desktop. Both are Mac with M1 chip.

I wrote down my codes in my desktop and transferred to my laptop.

However, if I run my codes, I get different results.

  1. I run several times in both computers to see if there is a racing problem with my multithreading. Within each computer, the results are always same.

  2. I just wrote down Random.seed!(1234) and tried rand(). Both computers give me the result.

What could possibly generate this?

Thank you very much

Hard to say without any code to look at. If you can get a minimum working example (MWE) that reproduces the different result on each machine, it will be much more productive for us to help!

1 Like

Which order of magnitude of differences are we talking about? Do you use the same julia and package versions?

1 Like

Are they running the same versions of Julia?

You might need to use a different psuedo-random number generator if you need stability.