Running in world age ... while current world is

#1

Hi,

When I run some functions in Julia I obtain this error: The applicable method may be too new: running in world age 26887, while current world is 26894.

If I run the code again, there is no error. This is a systematic behavior, every time I start Julia.

#2

Maybe try updating Julia? What version of Julia are you on? And did you download binaries, or build from source?

#3

I just downloaded the latest version of JuliaPro and I am running it from there. Does it help?

#4

This usually means that you are using eval to define new functions inside your function and then trying to call them. See the explanation here: Help calling a function defined from expressions

Calling eval inside a function is almost always the wrong thing to do. Often new Julia programmers make the mistake of trying to build up inner functions from strings or symbolic expressions that they eval, when the right thing is to just pass/define functions directly using ->.

2 Likes
#5

Check your startup.jl (under ~/.julia/config/ I believe). I’m sure you’re doing something similar to what Steven is indicating.