QP returns NUMERICAL_ERROR status

Hello all,

I have been trying to solve a quadratic problem with linear and box constraints. My objective function is convex. In most cases the problem gets solved fine (OPTIMAL status), but sometimes on larger examples I get the problematic status NUMERICAL_ERROR. Sometimes, there is still a feasible solution in the model and I am able to carry on just fine. In some other instances, there is no solution in the model and my algorithm stops (since it needs a feasible solution to carry on).

Since this happens in some cases and not others, I am not able to provide a minimal example.

Do you know anything about this status that might be of help here ? I use CPLEX 12.10 with JuMP v0.21.5 and CPLEX.jl’s current master branch.

Thank you for reading.

I can recommend trying other solvers like Gurobi, Xpress, and Ipopt.


Ipopt worked for me, thank you ! Still a bit confused as to why that happened, but for now it works for me.

1 Like

I suggest you read the following: https://www.gurobi.com/documentation/9.0/refman/num_grb_guidelines_for_num.html