Pycall is taking too much time to building and install

Hi everyone I’m using Julia I am trying to install the list or manifest (file)[DataScience/Manifest.toml at main · JuliaAcademy/DataScience · GitHub] included the JuliaAcademy datacience course.
Is it normal for the package to take hours to build the package for Julia 1.7?
the progress stayed at 8/11, how can I restart or stop the process, it has not shown errors yet, I am using a computer with windows 10, AMD Ryzen 4000 40 gigabytes of ram

I’ve just tried and:

Precompiling project...
  ✗ BinaryProvider
  195 dependencies successfully precompiled in 265 seconds. 218 already precompiled.
  1 dependency errored. To see a full report either run `import Pkg; Pkg.precompile()` or load the package

It definitely shouldn’t take hours. If it is stuck on one particular package maybe try installing that separately to see what happens?

1 Like

BinaryProvider? This Manifest must be very old. The PyCall “build” should basically involve installing python and numpy via conda.

It looks like @logankilpatrick and @nassarhuda were the last to touch the Manifest.

To stop the process, pressing Ctrl-C a few times should stop it.

To start debugging, let’s try this in the Julia REPL and report back the results.

using Pkg
pkg"activate --temp"
pkg"add PyCall"
1 Like

Thanks that works, worked in part, the system kept getting stuck in the build process, but with the instruction“PyCall”), of course, after stopping the process, apply your recommendation and apply the final instruction.

thank you for your answers :slight_smile: