I’m in need of representing a row vector where the entries themselves are row vectors, e.g.
a, b = RowVector([1,2]),RowVector([3,4]) r = RowVector([a',b'])
(In practice, my
b are special types that represent functionals, i.e., infinite-dimensional row vectors.)
The need to transpose
b seems superfluous, and the name
RowVector is confusing.
My proposal is to rename
TransposeVector and add a new implementation of
RowVector that doesn’t transpose the entries, so that the above code could be written in two ways:
a, b = RowVector([1,2]),RowVector([3,4]) r = TransposeVector([a',b']) r = RowVector([a,b])
I’m happy to make a pull request (I’ve added
ApproxFun.RowVector to do what I want) but wanted to check first whether there is an argument against this change.