Proposal: change `deg2rad` to `degtorad` or `deg_to_rad`

Hi guys!

Back when v0.7 was being conceived, I remember a discussion why eye should be dropped. One of the arguments is that this is something related to the English language, since I is pronounced almost like eye.

Isn’t is the same case with deg2rad? Hence, I would like to propose that we change this to degtorad or deg_to_rad. What do you think?

deg2rad and rad2deg are pretty much standard (scipy, php, Matlab, R).

Also we are kinda stuck with the name, at least until 2.0.


But eye was also pretty much standard in those languages (except php that I do not know). However, if a name change is not possible, than ok :slight_smile:

If you search for deg2rad in the julia issues, you will see there has been some discussion about those specific functions already.

1 Like