Prompting for private key location when developing a private repo

I’m trying to develop a private repo without success. Here is what I tried:

First generated a id_ed25519 key. Typing

dev “”


Private key location for '':

Following this link, I set JULIA_PKG_USE_CLI_GIT=true and tried again, but got the same prompt.

Following this suggestion, I added -m PEM when generating the key, repeated the above steps, but got the same error message.

Any suggestions?

julia> versioninfo()
Julia Version 1.8.2
Commit 36034abf260 (2022-09-29 15:21 UTC)
Platform Info:
  OS: macOS (arm64-apple-darwin21.3.0)
  CPU: 10 × Apple M1 Pro
  LIBM: libopenlibm
  LLVM: libLLVM-13.0.1 (ORCJIT, apple-m1)
  Threads: 1 on 8 virtual cores

Mandatory control question: Can you git clone your repo outside of Julia?

If you got the same prompt, you failed to set the environment variable effectively. Can you see it with ENV["JULIA_PKG_USE_CLI_GIT"] in your Julia session?

Indeed I didn’t set JULIA_PKG_USE_CLI_GIT=true effectively. After it is addressed,

dev “”

works fine even without -m PEM.

Thank you.