Problems with integer stack size


I am solving a optimization problem with 13104 variables the maximization is looped over some set of initial conditions. At some point I get the following problem:

Can some provide some information about what integer stack size means or what the problem is likely related too?

Thanks a lot.

Please provide a reproducible example

1 Like

Do you have an old version of MUMPS installed? This post mentions the same error message, and the suggestion is to use MUMPS 5.1.0 or above, or a different solver backend.

Thanks for the pointer but it seems like I am using the latest version which is in fact 1.3.0 and I still get the problem.

I am not allowed to give a repdroducible example sorry. But I was still hoping to get some insight on what the error could mean and if it is a frequent one and how people generally approach it.

It’s not frequent.

I am not allowed to give a repdroducible example sorry.

It’s hard to offer advice without a reproducible example, so that means we likely can’t help.

What is the full output of the Ipopt solve?

if it is a frequent one

I’ve never encountered it, but there are a few hits if you Google ([Ipopt] Segmentation fault due to MUMPS memory allocation).

It most likely relates to running out of memory.

You could try playing with the mumps_mem_percent option, Ipopt: Ipopt Options.

Otherwise, try a different linear solver: GitHub - jump-dev/Ipopt.jl: Julia interface to the Ipopt nonlinear solver

1 Like