Problem Installing RDatasets and DataFrames


#1

Can someone help me make sure my julia installation is correct? There are a few things that seem sketchy when I try to install and update the DataFrames package and the RDatasets Package

  • First, when I issue the command
    julia> Pkg.update(DataFrames)
    It takes a long time without giving me any notification, only to tell me that DataFrames has already been installed! I figured this might be the case, since I installed the JuliaPro distribution.
  • Second, when I run
    Pkg.update("Rdatasets")
    It runs for a long time, before telling me
    ERROR: Package Rdatasets is not installed (Rdatasets, not RDdatasets)
  • Third, when I try to push ahead and just use the two packages, I get the following:
julia> using RDatasets, Dataframes
WARNING: Method definition vcat(Array{Void, 1}) in module DataFrames at C:\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\Users\PeterDeffebach\AppData\Local\JuliaPro\pkgs-0.6.0.1\v0.6\DataFrames\src\abstractdataframe\abstractdataframe.jl:667 overwritten in module DataFrames at C:\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\Users\PeterDeffebach\AppData\Local\JuliaPro\pkgs-0.6.0.1\v0.6\DataFrames\src\abstractdataframe\abstractdataframe.jl:667.
WARNING: Method definition dump(IO, DataArrays.AbstractDataArray{T, 1} where T, Int64, Any) in module DataFrames at C:\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\Users\PeterDeffebach\AppData\Local\JuliaPro\pkgs-0.6.0.1\v0.6\DataFrames\src\abstractdataframe\abstractdataframe.jl:359 overwritten in module DataFrames at C:\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\\Users\PeterDeffebach\AppData\Local\JuliaPro\pkgs-0.6.0.1\v0.6\DataFrames\src\abstractdataframe\abstractdataframe.jl:359.
WARNING: replacing module DataFrames.
WARNING: requiring "Dataframes" in module "Main" did not define a corresponding module.

I think there is something wrong with the way I downloaded it. Can someone please help me out?


#2

Make sure you type RDatasets and DataFrames using the correct case.


#3

That was very stupid of me. However the file path in the warning is strange, is it not? Do you have any insight as to why it is using so many slashes?


#4

Yes it’s quite weird. I think there have been improvements in the development version, so maybe it’s worth trying with the nightly binaries. It’s also weird that the case mismatch only triggers a failure so late, I guess that’s related to the fact that the case-insensitity of the OS/filesystem. Maybe worth filing an issue: at least, we could check whether a module is defined with the same name but a different case to improve the error message.


#5

Wow thatnks for such a helpful reply! in other forums people would have just gotten annoyed with my forgetting the case.

I actually uninstalled JuliaPro and installed the basic Julia distribution. Everything is working better now. When I call using Rdatasets (wrong lower case d), it gives me
WARNING: replacing module RDatasets WARNING: requiring "Rdatasets" in module "Main" did not define a corresponding module.

Which is still not a super useful error message, but much better than the other distribution. Do i just file an issue on github with DataFrames to bring up the issue with JuliaPro?


#6

Better file an issue against JuliaLang/julia. Please post the link here too.