Precompiling Interpolations.jl failing

Using Julia 1.6:

using Interpolations
[ Info: Precompiling Interpolations [a98d9a8b-a2ab-59e6-89dd-64a1c18fca59]
ERROR: LoadError: LoadError: UndefVarError: SA not defined
  [1] top-level scope
    @ C:\Users\Berlin\.julia\packages\Interpolations\qHlUr\src\lanczos\lanczos.jl:110
  [2] include(mod::Module, _path::String)
    @ Base .\Base.jl:386
  [3] include(x::String)
    @ Interpolations C:\Users\Berlin\.julia\packages\Interpolations\qHlUr\src\Interpolations.jl:1
  [4] top-level scope
    @ C:\Users\Berlin\.julia\packages\Interpolations\qHlUr\src\Interpolations.jl:476
  [5] include
    @ .\Base.jl:386 [inlined]
  [6] include_package_for_output(pkg::Base.PkgId, input::String, depot_path::Vector{String}, dl_load_path::Vector{String}, load_path::Vector{String}, concrete_deps::Vector{Pair{Base.PkgId, UInt64}}, source::Nothing)
    @ Base .\loading.jl:1213
  [7] top-level scope
    @ none:1
  [8] eval
    @ .\boot.jl:360 [inlined]
  [9] eval(x::Expr)
    @ Base.MainInclude .\client.jl:446
 [10] top-level scope
    @ none:1
in expression starting at C:\Users\Berlin\.julia\packages\Interpolations\qHlUr\src\lanczos\lanczos.jl:110
in expression starting at C:\Users\Berlin\.julia\packages\Interpolations\qHlUr\src\Interpolations.jl:1
ERROR: Failed to precompile Interpolations [a98d9a8b-a2ab-59e6-89dd-64a1c18fca59] to C:\Users\Berlin\.julia\compiled\v1.6\Interpolations\jl_EEE8.tmp.
 [1] error(s::String)
   @ Base .\error.jl:33
 [2] compilecache(pkg::Base.PkgId, path::String, internal_stderr::Base.TTY, internal_stdout::Base.TTY)
   @ Base .\loading.jl:1360
 [3] compilecache(pkg::Base.PkgId, path::String)
   @ Base .\loading.jl:1306
 [4] _require(pkg::Base.PkgId)
   @ Base .\loading.jl:1021
 [5] require(uuidkey::Base.PkgId)
   @ Base .\loading.jl:914
 [6] require(into::Module, mod::Symbol)
   @ Base .\loading.jl:901

And the version:

(@v1.6) pkg> status Interpolations
      Status `C:\Users\Berlin\.julia\environments\v1.6\Project.toml`
  [a98d9a8b] Interpolations v0.13.1

Any ideas why this is happening?


What StaticArrays version are you on?


julia> using StaticArrays

julia> SA


I get this:

julia> using StaticArrays

julia> SA
ERROR: UndefVarError: SA not defined

My version:

(@v1.6) pkg> status StaticArrays
      Status `C:\Users\Berlin\.julia\environments\v1.6\Project.toml`
  [90137ffa] StaticArrays v0.11.1

And using

] up StaticArrays

the version no stays the same…

You might have something that blocks it from getting updated. What if you do ] add StaticArrays@1?

1 Like

Yeah that worked, I removed all my packages with odd dependancies then could install and run this.


1 Like

Hy there. I’m having the same issue as the one reported by Tim and I tried the suggestion that Kristoffer gave. However, when I run ] add StaticArrays@1, I get the following:

ERROR: Unsatisfiable requirements detected for package StaticArrays [90137ffa]:
StaticArrays [90137ffa] log:
├─possible versions are: [0.8.0-0.8.3, 0.9.0-0.9.2, 0.10.0, 0.10.2-0.10.3, 0.11.0-0.11.1, 0.12.0-0.12.5, 1.0.0-1.0.1, 1.1.0-1.1.3, 1.2.0-1.2.2] or uninstalled
├─restricted to versions 1 by an explicit requirement, leaving only versions [1.0.0-1.0.1, 1.1.0-1.1.3, 1.2.0-1.2.2]
└─restricted by compatibility requirements with IntervalArithmetic [d1acc4aa] to versions: [0.8.0-0.8.3, 0.9.0-0.9.2, 0.10.0, 0.10.2-0.10.3, 0.11.0-0.11.1, 0.12.0-0.12.5] — no versions left
└─IntervalArithmetic [d1acc4aa] log:
├─possible versions are: [0.14.0, 0.15.0-0.15.2, 0.16.0-0.16.7, 0.17.0-0.17.8, 0.18.0-0.18.2] or uninstalled
└─restricted to versions 0.16.7 by an explicit requirement, leaving only versions 0.16.7

there seems to be some conflict with the package IntervalArithmetic. any clue how to solve this? should I just uninstall this package?