Precompile errors Makie (AbstractPlotting)

Attempted to try out Makie, but the precompile fails. I’m including a sample for the AbstractPlotting precompile, but it’s the same for CairoMakie, etc. I know similar problems are reported from time to time, but none of the solutions seem to resolve this.

Thanks in advance!

Precompile error trace…

Results of versioninfo()…

And package status…

I tried to reproduce by

(@v1.5) pkg> activate MakieTest

(MakieTest) pkg> add AbstractPlotting

and didn’t re- but produced another error.
After going back to the default environment with

(MakieTest) pkg> activate

(@v1.5) pkg> add AbstractPlotting

and add and using worked. So it is perhaps a bug with AbstractPlotting and different environments.

Solved… appears to have been incomplete removal of earlier versions or some such.

  1. did a " pkg> rm " of everything Makie related.

  2. did a " pkg> gc " to ensure everything was cleared out

  3. did " pkg> add AbstractPlotting#master " & also CairoMakie#master (NOTE: the versions installed are slightly different from the above pics… AbstractPlotting is up to v0.15.12. Not sure if that changes things also.)

  4. at this point, “using AbstractPlotting” & “using CairoMakie” now work.

  5. (this is very important) apply liberal amounts of salt over the shoulder and rattling of chicken bones to ensure the gremlins have been properly appeased.