Point Julia to Cbc built from source

Hello All,

I am trying to get JuMP and Cbc to use multithreading. Turns out that in order to do this you have to build Cbc from source with the --enable-cbc-parallel option.

I have followed the cbc build instructions instructions here: https://github.com/coin-or/Cbc to build Cbc using coinbrew.

Now I need to point Julia to my newly built version of Cbc. This is the part I am having trouble with.

According to https://github.com/JuliaOpt/Cbc.jl all that is needed is:
ENV[“JULIA_CBC_LIBRARY_PATH”]=“path/to/custom/built/binaries”
then
import Pkg; Pkg.build(“Cbc”)

I point my julia cbc library path to the dist/lib folder containing the libCbc.la and libCbcSolver.la files, but keep getting the following error:
┌ Error: Error building Cbc:
│ ERROR: LoadError: Could not install custom libraries from C:/Users/me/path/to/dist/lib.
│ To fall back to BinaryProvider call delete!(ENV,“JULIA_CBC_LIBRARY_PATH”) and run build again.
│ Stacktrace:
│ [1] error(::String) at .\error.jl:33
│ [2] top-level scope at C:\Users\me.julia\packages\Cbc\zMLXd\deps\build.jl:66
│ [3] include at .\boot.jl:328 [inlined]
│ [4] include_relative(::Module, ::String) at .\loading.jl:1105
│ [5] include(::Module, ::String) at .\Base.jl:31
│ [6] include(::String) at .\client.jl:424
│ [7] top-level scope at none:5
│ in expression starting at C:\Users\me.julia\packages\Cbc\zMLXd\deps\build.jl:60

Any help would be very much appreciated. Thanks

Just for your information, I moved your question to the Domains/Optimization section, so it’s more likely to be seen by JuMP users and developers.

You may need to point it at the actual DLLs in /bin. (Or perhaps even the parent of /lib and /bin.) I’m not sure what’s needed on Windows.

Thanks for the reply odow! I have tried pointing it to /lib, /bin, and even their parent; /dist.
But I get the same error every time.

Is there any chance you know what file types the package manager is looking for?

Install Cbc.jl using the provided binaries, then look at the deps folder to see what was installed.

I haven’t used custom binaries with binary builder on Windows, so I’m not sure.

Hi Odow,

Do you have any experience doing so in a unix environment? I have access to an ubuntu machine.