Plots still broken in Julia1.80 (Mac)

Earlier this year, there was a reported issue with Julia1.7 and Plots (see

This same error apparently still has not been resolved as of Julia1.80 (issue was originally reported for a Ubuntu system, but my error on the Mac is identical).
This is a “showstopper” for my teaching, unfortunately.

I would be extremely grateful for any help [thanks!]

[PS Unless I resolve this somehow in the next few days, I will have to drop Julia for this year’s teaching, as I have a very large class of mostly non-technical students]

If it helps, new Julia users using 1.8 would probably see this, like I do (on a Mac) with a fresh installation of Plots:

If you’re seeing errors, perhaps post a listing of the output of status?

Thank you. It had worked like that for me initially and then I had opened it for the first time in JupyterLab and it no longer worked (not even at the console) after that.

I just ran a comprehensive update and it seems to be working again.

Could it be an environment issue with Jupyterlab, I wonder?

Hanging? Frozen? Unresponsive? Crash? Errors in Console? More info might help people help you. (I’ve never heard of Jupyterlab, so I can’t assist further. Pluto’s quite good!)

All sorts of unmet dependencies after invoking “using Plots” (virtually exact error message quoted at the top above)
Thanks :slight_smile:

Well, Pluto.jl works perfectly for me, with no errors.

So there might be some non-Julia issues with your computer, or perhaps you’re seeing issues with other packages which we can’t guess at. Again, more information will allow people to help. :slight_smile:

1 Like

To help us help you, post

  1. Any errors you get when doing using Plots in a clean environment
  2. The ] st result when you replicate your error.

Yes, the more I look into it, the more it seems that JupyterLab is the culprit. So rather than dropping Julia for my upcoming teaching, it looks like I need to drop JupyterLab (in my case, probably in favour of VSCode with Notebook extension).

Thank you and sorry for not being clearer.

The error at the top of this post is what happens after using Plots in a fresh environment, but only when run in JupyterLab (I now see). For all other contexts (including VSCode, Pluto, Neptune, etc.) there is no error, though these do not work anymore after the command is attempted JupyterLab.

From reading it appears that an initialisation of an important environment variable (LD_LIBRARY_PATH=“”) has been omitted from the steps involved in the invocation of a kernel in JupyterLab.

My apologies for the confusion of a Julia issue with what appears to be a JupyterLab issue.

Using LD_LIBRARY_PATH is nearly always a non-solution for developers and never a solution for regular users. There is likely a conflict between the jupyterlab libraries and the julia libraries loaded when starting the julia kernel. This can probably be investigated using strace and/or LD_DEBUG and such on linux.

Thanks for the heads-up. Lately, I have only been using Notebooks in VSCode and found it to be essentially bug-free. Students are a bit more familiar with JupyterLab, but this isn’t the first bug I have encountered, so I think I will have them use VSCode for my classes.