Pkg.update() in V0.5.0


#1

I installed V0.5.0 of Julia. When I run a Pkg.Update() I get:

Note that I also have 0.4.6 install and do not get this error. I can add packages and update, etc.

julia> Pkg.update()
INFO: Initializing package repository Z:\.julia\v0.5
INFO: Cloning METADATA from https://github.com/JuliaLang/METADATA.jl
ERROR: GitError(Code:ERROR, Class:OS, Failed to set proxy: The parameter is incorrect.
)
 in macro expansion at .\libgit2\error.jl:99 [inlined]
 in clone(::String, ::String, ::Base.LibGit2.CloneOptions) at .\libgit2\repository.jl:191
 in #clone#109(::String, ::Bool, ::Ptr{Void}, ::Nullable{Base.LibGit2.AbstractCredentials}, ::Function, ::String, ::String) at .\libgit2\libgit2.jl:327
 in (::Base.LibGit2.#kw##clone)(::Array{Any,1}, ::Base.LibGit2.#clone, ::String, ::String) at .\<missing>:0
 in (::Base.Pkg.Dir.##4#6{String,String})() at .\pkg\dir.jl:49
 in cd(::Base.Pkg.Dir.##4#6{String,String}, ::String) at .\file.jl:48
 in init(::String, ::String) at .\pkg\dir.jl:47
 in #cd#1(::Array{Any,1}, ::Function, ::Function, ::String, ::Vararg{Any,N}) at .\pkg\dir.jl:28
 in update() at .\pkg\pkg.jl:210

#2

Do you have any proxy-related environment variables set?


#3

There are no environment variables set. A couple other details.

1.) Julia 0.4.6 works fine
2.) I am using Windows 10
3.) git works OK otherwise.
4.) I setup Julia running in a VM (windows 10) on the same machine and Pkg.update() worked.


#4

One other note:

I brought my laptop home and am now able to update packages, etc. It is definitely something to do with the network at the university lab. I have to log into a Windows Domain. There could be some some firewall policy that trickles down. When I get back in I will try the latest nightly to see if it is different.

The fact that 0.4.3 works means there is some sort of regression in 0.5.0