Pkg.develop() causing package to downgrade

I am having trouble using pkg> develop on a registered Julia package. Here’s the situation:
When I enter Pkg mode on the REPL and add ViscousFlow, the correct package at the most recent version gets downloaded from the git repository. After this, if I type pkg> status I see the correct, most recent version, 0.3.3:

Status `~/.julia/environments/v1.3/Project.toml`
[103da179] ViscousFlow v0.3.3

However, when I proceed to typing develop ViscousFlow, I automatically get downgraded to 0.3.0. The new Pkg.status() list says:

[103da179] ViscousFlow v0.3.0 [`~/.julia/dev/ViscousFlow`]

This is important because along with an older version which had a known bug, this forcefully removes some dependencies which 0.3.3 calls for, and without which the package does not work; in the following output to develop ViscousFlow, notice how two packagesConstrainedSystems and RigidBodyTools are removed, among other things:

 Resolving package versions...
  Updating `~/.julia/environments/v1.3/Project.toml`
  [103da179] ↓ ViscousFlow v0.3.3 ⇒ v0.3.0 [`~/.julia/dev/ViscousFlow`]
  Updating `~/.julia/environments/v1.3/Manifest.toml`
  [3e975e5d] - CartesianGrids v0.1.3
  [3da002f7] ↓ ColorTypes v0.10.4 ⇒ v0.10.0
  [c257ce95] - ConstrainedSystems v0.1.1
  [91a5bcdd] ↓ Plots v1.4.0 ⇒ v0.27.1
  [3cdcf5f2] ↓ RecipesBase v1.0.1 ⇒ v0.8.0
  [01d81517] - RecipesPipeline v0.1.10
  [befc5f09] - RigidBodyTools v0.1.1
  [3a884ed6] ↓ UnPack v1.0.1 ⇒ v0.1.0
  [103da179] ↓ ViscousFlow v0.3.3 ⇒ v0.3.0 [`~/.julia/dev/ViscousFlow`]

I have tried a couple of different things. For one thing, I have tried a couple of different Julia installations, including a fresh install of 1.3.1, but that doesn’t seem to have any effect. I also suspected that this may be due to left-over files in ~/.julia/dev/ViscousFlow, so I rm'd the contents of the ~/.julia/dev/ folder and re-tried the above process. Without fail, develop-ing the package causes it to revert from 0.3.3 to 0.3.0. I have also tried forcing the version number on the develop command by appending @0.3.3 to the end of the package name; no luck.

Even more puzzlingly, on another installation of Julia on a different machine (where I have 1.3.0), the same problem does not seem to occur; there, when I develop ViscousFlow, the development environment that I get has 0.3.3 and all of its dependencies, as I would like.

Grateful for any help!