PackageCompiler Executable - Plots not showing up

Hi all,

I just figured out how to compile my code into an executable using PackageCompiler. This has worked great. However, upon running the code, none of the plot windows show up. For my project it is necessary that the user see real-time images. This problem has only started now that I am running from the executable. running the .jl file in the powershell still provides a pop-up window with the plots.

I am running Windows 10 and plotting with PyPlot.



Try: PyPlot.plot(1:100);

It may be that the plotting window is being closed since the program exits - have you tried saving the plot to a file instead and checking whether the plot is being produced at all?

Thanks for your quick reply. Show() does work, however the code now does not display any information to the terminal until the plot is closed. The results are still kept track of just not displayed until the plot is closed. Additionally, new plots will not be shown until the previous plot is closed.
I am generating plots iteratively and refreshing the same figure. Currently, the figure must be closed in order to refresh itself with the next iteration. The code also seems to hang at this point and will not continue past the image generation.


Could you plot in @async?