Package ZeroMQ_jll does not have JLLWrappers in its dependencies

Hi all,

I am new to Julia and tried installing it on both a Windows PC as well as a Macbook. On both systems I get the same error, but if I google it, I cannot find any related problems.

I installed julia 1.5.2 and connected it to Jupyter. It all worked fine. Then I started the Data Science course on JuliaAcademy and opened the first notebook (Data.ipynb).

This is the moment it all collapses. I get the following error in the terminal:

**ERROR:** LoadError: ArgumentError: Package ZeroMQ_jll does not have JLLWrappers in its dependencies:

- If you have ZeroMQ_jll checked out for development and have

added JLLWrappers as a dependency but haven't updated your primary

environment's manifest file, try `Pkg.resolve()`.

- Otherwise you may need to report an issue with ZeroMQ_jll

I have no clue what to do, so if anyone could please help me, it would be highly appreciated.

Well, I think I fixed the problem. There were a ‘Manifest’ and ‘Project’ file in the folder that were overwriting the files from the Julia app.

Once I removed them and installed the packages, I seems to work right now.

2 Likes

Thanks so much for sharing. Same for me. I deleted Project.toml and Manifest.toml - and the error message " Package ZeroMQ_jll does not have JLLWrappers in its dependencies" stopped. All fine.

Would you please provide directory for two files?