Package issue with Master 1.1.0-DEV.854 (2018-12-11)


#1

For several weeks I have been running an application using both the release 1.0.2 version and the latest master. All has worked well. Then in the last few days master started giving problems. 1.0.2 updates correctly and runs the application fine, but attempting to update packages on master produces (snippet only, more on request):


[4ec0a83e] + Unicode
ERROR: KeyError: key “Pkg” not found
Stacktrace:
[1] getindex at ./dict.jl:478 [inlined]
[2] #109 at /home/colin/gitprogs/julia/usr/share/julia/stdlib/v1.1/Pkg/src/Types.jl:1569 [inlined]
[3] _all(::getfield(Pkg.Types, Symbol("##109#111")){Dict{String,Bool}}, ::Dict{String,Base.UUID}, ::Colon) at ./reduce.jl:663

I have tried deleting the registry directory, this was downloaded again, but no difference for master. It looks like 1.0.2 and 1.1.0 both use the same package info, this was not the case for say 0.5/0.6 so I wonder if there has been a change for one but not the other. Is this a reportable issue?


#2

You need to clean the usr folder and recompile, see https://github.com/JuliaLang/julia/pull/30075#issuecomment-442151605