Node.js 12 actions deprecation warning on github

In several CI runs, I see a warning like

Node.js 12 actions are deprecated. For more information see: Please update the following actions to use Node.js 16: actions/checkout, actions/checkout

Could someone point towards an update that might resolve this, if this has been addressed already?

Would changing this line be enough:

 - uses: actions/checkout@v2


 - uses: actions/checkout@v3

as it seems GitHub - actions/checkout: Action for checking out a repo suggests that v3 is Updated to the node16 runtime by default ?

Yes, that should do it, I believe.

For folks that are using the package butler system, I just updated it so it should now automatically make those changes for your repos. For those that want to try this (because they are tired of manually keeping GitHub Workflow files up-to-date), GitHub - JuliaLang/PkgDev.jl: Tools for Julia package developers.

@davidanthoff an @jishnub I was getting the same error as u were facing ,when I tried to run the draft-pdf.yml file in my repo it is showing …followin error

/usr/bin/docker run --name openjournalsinaralatest_fb3592 --label 49859c --workdir /github/workspace --rm -e "INPUT_JOURNAL" -e "INPUT_PAPER-PATH" -e "GIT_SHA" -e "JOURNAL" -e "HOME" -e "GITHUB_JOB" -e "GITHUB_REF" -e "GITHUB_SHA" -e "GITHUB_REPOSITORY" -e "GITHUB_REPOSITORY_OWNER" -e "GITHUB_REPOSITORY_OWNER_ID" -e "GITHUB_RUN_ID" -e "GITHUB_RUN_NUMBER" -e "GITHUB_RETENTION_DAYS" -e "GITHUB_RUN_ATTEMPT" -e "GITHUB_REPOSITORY_ID" -e "GITHUB_ACTOR_ID" -e "GITHUB_ACTOR" -e "GITHUB_TRIGGERING_ACTOR" -e "GITHUB_WORKFLOW" -e "GITHUB_HEAD_REF" -e "GITHUB_BASE_REF" -e "GITHUB_EVENT_NAME" -e "GITHUB_SERVER_URL" -e "GITHUB_API_URL" -e "GITHUB_GRAPHQL_URL" -e "GITHUB_REF_NAME" -e "GITHUB_REF_PROTECTED" -e "GITHUB_REF_TYPE" -e "GITHUB_WORKFLOW_REF" -e "GITHUB_WORKFLOW_SHA" -e "GITHUB_WORKSPACE" -e "GITHUB_ACTION" -e "GITHUB_EVENT_PATH" -e "GITHUB_ACTION_REPOSITORY" -e "GITHUB_ACTION_REF" -e "GITHUB_PATH" -e "GITHUB_ENV" -e "GITHUB_STEP_SUMMARY" -e "GITHUB_STATE" -e "GITHUB_OUTPUT" -e "RUNNER_OS" -e "RUNNER_ARCH" -e "RUNNER_NAME" -e "RUNNER_TOOL_CACHE" -e "RUNNER_TEMP" -e "RUNNER_WORKSPACE" -e "ACTIONS_RUNTIME_URL" -e "ACTIONS_RUNTIME_TOKEN" -e "ACTIONS_CACHE_URL" -e GITHUB_ACTIONS=true -e CI=true -v "/var/run/docker.sock":"/var/run/docker.sock" -v "/home/runner/work/_temp/_github_home":"/github/home" -v "/home/runner/work/_temp/_github_workflow":"/github/workflow" -v "/home/runner/work/_temp/_runner_file_commands":"/github/file_commands" -v "/home/runner/work/devolearn/devolearn":"/github/workspace" openjournals/inara:latest  "-o pdf" ""
[INFO] Running filter /usr/local/share/openjournals/data/filters/parse-latex.lua
[INFO] Completed filter /usr/local/share/openjournals/data/filters/parse-latex.lua in 7 ms
[INFO] Running filter /usr/local/share/openjournals/data/filters/inline-cited-references.lua
[INFO] Completed filter /usr/local/share/openjournals/data/filters/inline-cited-references.lua in 3 ms
[INFO] Loaded apa.csl from /usr/local/share/openjournals/apa.csl
[INFO] Running filter /usr/local/share/openjournals/data/filters/normalize-metadata.lua
Error running filter /usr/local/share/openjournals/data/filters/normalize-metadata.lua:
attempt to index a nil value
stack traceback:
15 in upvalue 'normalize_authors'
	...l/share/openjournals/data/filters/normalize-metadata.lua:56: in function 'Meta'

and link for the error here

pls help me out with this error