NLopt with JuMP producing an error

I am trying to minimize a function subject to two boundary constraints and a linear inequality constraint. Here is a simplified version of what I am trying to do

using JuMP
using NLopt
fopt2(bprime, pimortg) = bprime^2 + pimortg^2
m_p2 = JuMP.Model(solver=NLoptSolver(algorithm=:LN_COBYLA))
JuMP.@variable(m_p2, bprime >= 0)
JuMP.@variable(m_p2, pimortg >= 0.00008)
JuMP.register(m_p2,:fopt2,2,fopt2,autodiff = true)
JuMP.@NLobjective(m_p2, Min, fopt2(bprime,pimortg))
res             = JuMP.solve(m_p2)

The minimum point should be 0 and 0.00008. However, when I run it I get the error

ArgumentError: invalid NLopt arguments

Same happens when I add the constraint

JuMP.@constraint(m_p2,  -pimortg - 0.9709*bprime >=-0.03)

Again, the same error.

Overall both JuMP and NLopt work for other problems that I have, but not for this one.

Thanks for help,

@myroslav. I know this problem of yours was many years ago, but did you manage to solve the problem? If yes, would you mind sharing the solution for greater community learning? Thanks.