Need RaspberryPi - ARM Julia package testers

Looks like you need an apt-get dist-upgrade.

seth@violet ~ $ sudo apt-get dist-upgrade
Reading package lists... Done
Building dependency tree
Reading state information... Done
Calculating upgrade... Done
0 upgraded, 0 newly installed, 0 to remove and 0 not upgraded.

Many ubuntus have a do-release-upgrade or some such thing. Or perhaps have
to install from the raspbian image?

Yup, got it. Need to get to Jessie. On it now. Thanks.

Awesome, worked out of the box on my Pi3, running Raspbian GNU/Linux 8 \n \l kernel 4.4.38-v7+. QML.jl seems to work at least partially out of the box, the test segfaults but this seems to work and run reasonably smoothly:

Pkg.add("QML")
cd(Pkg.dir("QML"))
include("example/gui.jl")

This requires QML development packages, cmake and GCC installed (it tries to do that automatically but that will probably fail).

1 Like

Do you know which test segfaulted?

To be clear, I ran the QML.jl tests, it was either properties.jl or qmlcomponent.jl, probably this is a CxxWrap.jl or QML.jl bug, so I intend to take a look when I have some more time to play around with the Pi.

Update: after an apt-get -f install things appear to be working normally.

I would expect that when you install via apt, all this will come out ok.
Looks like things are working after all this - so that is good.

-viral

Things are slow, but working nicely. Thanks!

Looks like we are good to go. The package also works on the other Pis, but is incredibly slow on older or slower processors. Time to get those compiler improvements and the interpreter in.

Viral,

Thank you for all your work on this. Getting Julia running on an RPi really opens up the possibility for wider deployment of the language.

Also, do see the JuliaBerry organization:

https://juliaberry.github.io/

1 Like

Julia in Raspbian now. You can see Julia in here:
http://archive.raspberrypi.org/debian/dists/jessie/main/binary-armhf/Packages

And also do see Ben Nuttall’s tweet:

And the screenshots he posted:

-viral

How RPi specific this package is? Would it be worth to try it on e.g. OrangePi?

It’ll probably work but will have worse performance than the generic Linux binary.

1 Like

I installed Julia via apt on two Raspberry Pi 3’s running fully update Jessie distros. On one it ran without problem and on the other I get a segmentation fault.

What can I do to find the problem?

Please open an issue, including the output that you get.

It would also be useful if you can run it with a debugger: see these instructions (I believe julia-debug should be included in the package)

I finally got around to trying it but couldn’t find julia-debug on the Raspberry Pi.

I might have removed it to keep the binary small. It is there in the stock
binaries.

For 0.6 we could bring back julia-debug if deemed important.

-viral