Module Not Reloading

module

#1

I had a personal module that worked back in Julia 0.4.8 and I am in the process of updating it to Julia 0.6. I’ve updated all the syntax, but I have to change the name of the module from “Lattices” to “Lattices2” to get it to work.

Even though my “Lattices.jl” file has been updated to the new version, when I try using Lattices, I not only get errors about a package I don’t call anymore, but also none of my variables and functions get imported.

I’ve tried reload("Lattices"), but that does not help at all.


#2

Perhaps Pkg.rm("Lattices") and then rename your Lattices2. Alt. remove it manually in .julia/v0.6/.


#3

Pkg.rm("Lattices") gives INFO: Package Lattices is not installed.

There is nothing to remove in ./julia/v0.6 either.


#4

Then it has to exist in a folder that is set in the LOAD_PATH variable.


#5

Does “.” count?


#6

Do you have a file/directory containing old Lattices module in your current directory?
If so, then remove it.
In any case, why do you want “.” in your LOAD_PATH?


#7

Found the problem. The same package existed elsewhere in on my computer. I thought I was loading the local one, but I was loading one at a different location.

Thanks for your time, and sorry it ended up being so silly. But I guess the problem is usually silly.