Lsp-julia (Emacs) not detecting installed packages. (And REPL extra)

[Using Doom Emacs]

I’ve been trying to setup my Doom Emacs install, while I’ve managed to make lsp-mode work with Julia through this small piece:

(after! julia-mode
  (add-hook! 'julia-mode-hook
    (setq-local lsp-enable-folding t
                lsp-folding-range-limit 100)))

I haven’t managed to make lsp detect the installed packages. I’ve setup my `lsp-julia-default-environment’ to mine but it still doesn’t work.

Doom Emacs uses lsp-julia package for Emacs.

REPL extra: (Maybe an extra thread?) I frequently work with Julia in multithreaded mode but the startup delay and memory footprintm makes it so I don’t want it to be the default option every time I want to tinker with something. I’ve found that I could setup several possible Julia executables here, but I don’t know how to make it so the second one spawns a Julia REPL with the -p option.

It’s not a direct answer, but I’ve found eglot-jl a bit easier to get working in Doom than lsp-mode: GitHub - non-Jedi/eglot-jl: Wrapper for using Julia LanguageServer.jl with emacs eglot

To add some detail, with eglot-jl you can just set: (setq eglot-jl-language-server-project "path/to/my/project")

With lsp it should be lsp-julia-default-environment

Managed to make both work but I have issues with both:

1- eglot is slow when dealing with out-of-file declarations that have been included or imported.

2- lsp-julia's indexing takes ages and apparently I have to do it every time I update my install. It’s also not light on the CPU in normal workload.

It appears the thing I need to really change is my CPU in all this. Thanks @Satvik !