LoadError: UndefVarError: subset not defined

So I installed and loaded the package Lathe.jl and it seemed to have a conflict with DataFrameMeta.jl. Now it seems my DataFrameMeta is corrupted with subset not working:

rawdf = @subset(rawdf, :has_iata .== "Yes", :iata .!= "9999999") 

Error code:

ERROR: LoadError: UndefVarError: subset not defined
Stacktrace:
  [1] subset_helper(::Symbol, ::Expr, ::Vararg{Expr, N} where N)
    @ DataFramesMeta C:\Users\xxxxxx\.julia\packages\DataFramesMeta\EDzWO\src\macros.jl:427
  [2] var"@subset"(__source__::LineNumberNode, __module__::Module, x::Any, args::Vararg{Any, N} where N)
    @ DataFramesMeta C:\Users\xxxxx\.julia\packages\DataFramesMeta\EDzWO\src\macros.jl:577
  [3] eval
    @ .\boot.jl:360 [inlined]
  [4] eval
    @ .\Base.jl:39 [inlined]
  [5] repleval(m::Module, code::Expr, #unused#::String)
    @ VSCodeServer c:\Users\xxxxxx\.vscode\extensions\julialang.language-julia-1.4.0\scripts\packages\VSCodeServer\src\repl.jl:157
  [6] (::VSCodeServer.var"#69#71"{Module, Expr, REPL.LineEditREPL, REPL.LineEdit.Prompt})()
    @ VSCodeServer c:\Users\xxxxxx\.vscode\extensions\julialang.language-julia-1.4.0\scripts\packages\VSCodeServer\src\repl.jl:123
  [7] with_logstate(f::Function, logstate::Any)
    @ Base.CoreLogging .\logging.jl:491
  [8] with_logger
    @ .\logging.jl:603 [inlined]
  [9] (::VSCodeServer.var"#68#70"{Module, Expr, REPL.LineEditREPL, REPL.LineEdit.Prompt})()
    @ VSCodeServer c:\Users\xxxxxx\.vscode\extensions\julialang.language-julia-1.4.0\scripts\packages\VSCodeServer\src\repl.jl:124
 [10] #invokelatest#2
    @ .\essentials.jl:708 [inlined]
 [11] invokelatest(::Any)
    @ Base .\essentials.jl:706
 [12] macro expansion
    @ c:\Users\xxxxxx\.vscode\extensions\julialang.language-julia-1.4.0\scripts\packages\VSCodeServer\src\eval.jl:34 [inlined]
 [13] (::VSCodeServer.var"#53#54")()
    @ VSCodeServer .\task.jl:411
in expression starting at REPL[72]:1

These are all of the things I have tried without luck:

Restarted VSCode
Wiped the library folder and the registry folder and reloaded all packages (without Lathe)
Updated DataFrameMeta
Using the gc command
I’ve also tried the simple DataFramesMeta.@subset() and get the same error

stopping short of wiping Julia entirely and starting over from scratch is there some option I am missing?

Found this:

Seems like it was a recent known issue and that I need the most recent versions of DataFrames… Thinking that I had just wiped and reinstalled all the packages that they would be the newest version I thought to check and lo and behold:

image

I will post if this is the solution or not, but I am surprised that pkg.add(“DataFrames”) didn’t seem to add the latest version…