LoadError: ArgumentError: hasproperty of NULL PyObject

I am trying to add FLOWNoise pkg in my env however I am getting the following error:

I did the following:
ENV[“PYTHON”] = “”

I am still getting the same error. I kindly request your help.

Thank you


I had the same problem! Maybe there’s a bug with the installation order.
Try adding FLOWNoise separately with:
] add https://github.com/byuflowlab/FLOWNoise

This fixed my installation. Afterwards I could import FLOWUnsteady and FLOWNoise.

This PyObject Error, which I do not get, seems related to PytPlot.jl which is a dependency, and I suggest the project migrates to the drop-in-replacement project PythonPlot.jl.

I’m not exactly sure why it fixed, but order of installation of (at least of registered) packages shouldn’t matter.

I got:

(@v1.9) pkg> add https://github.com/byuflowlab/FLOWUnsteady
     Cloning git-repo `https://github.com/byuflowlab/FLOWUnsteady`
    Updating git-repo `https://github.com/byuflowlab/FLOWUnsteady`
   Resolving package versions...
ERROR: Unsatisfiable requirements detected for package FLOWVLM [1a3ff0be]:
 FLOWVLM [1a3ff0be] log:
 ├─FLOWVLM [1a3ff0be] has no known versions!
 └─restricted to versions 2.1.2-2 by FLOWUnsteady [b491798d] — no versions left
   └─FLOWUnsteady [b491798d] log:
     ├─possible versions are: 3.2.1 or uninstalled
     └─FLOWUnsteady [b491798d] is fixed to version 3.2.1

even after:

(@v1.9) pkg> help activate --temp

seemingly because of similar:

(jl_aVUcRQ) pkg> add https://github.com/byuflowlab/FLOWVLM
ERROR: Unsatisfiable requirements detected for package AirfoilPrep [008c61af]:

(jl_aVUcRQ) pkg> add https://github.com/byuflowlab/AirfoilPrep
     Cloning git-repo `https://github.com/byuflowlab/AirfoilPrep`
Username for 'https://github.com'

i.e. since that unregistered package needs a password, at least for me. These packages seem very intriguing, and should they be registered? Are you the author?

Yup, that’s right it was a PyPlot dependency error. I just played around with a different version of the dependency packages and it finally works now.

Thanks for the help!

1 Like