Lightly OT: MD as abbreviation of multiple dispatch?


I’m starting to document a few things and i’m wondering if there is a proper abbreviation for multiple dispatch? Like this function call is single type only API, this here is MD ?


I am not sure it is an established acronym, but aside from that, the more immediate problem could be that unless you enforce that some functions have only a single method (eg via unit tests), it could change quickly and make the documentation out of sync with the code. Let alone other modules extending the function (may not seem a concern now, but one cannot predict).

This is something I would not document, as it is easily discoverable via methods. Moreover, a well-designed API makes various methods blend in seamlessly to perform a single function (as much as that makes sense). Eg Base.+ has zillion methods, but one can conceptualize it as a single function.


i actually subscribe your view. Here (Cairo.jl) i try to stay close to the C-API libcairo calls - which are by definition single type calls - and list in the documentation ‘utility’ functions that enable a MD/more julian interface.