libLLVM Issue when Adding/Building Packages

Hi there,

I tried to install JuMP 0.18.4 in Julia version 1.0.1, and it succeeded. When I tested the package, however, it told me to rebuild the SpecialFunctions. But then it failed to build this because of a LoadError: Unable to open libLLVM! as follows.

When I was firstly installing JuMP, it also reported this issue and failed, but later it succeeded after I tried and failed rebuilding the SpecialFunctions, which is weird.

Can somebody help me out with this? Thank you!


Here is some more discussion:

Thank you! But I think based on that site there is currently no solution towards this problem…

Some guys said they can correct this in ubuntu by redirecting the system manually to the library, but I do not even know where I can find this library in Mac. The only information I know about this is its version, i.e. libLLVM-6.0.0, via using versioninfo() to show.

based on

if you are using openSUSE, please:

sudo zypper in llvm-devel

trying to contact the maintainer of science repo, hope it could be solved proerly.

1 Like