Jupyter can't find Julia 1.0.3 Kernel in Windows


#1

I get a long list of errors ending in “file not found” when I click on the kernel icon.


#2

Please give more details about the problem. Which version of Julia do you have installed? Do you have the IJulia package installed? How did you install Jupyter?


#3

Windows 10. Julia 1.10. IJulia is installed. I don’t have this problem with Julia 0.70. Here’s the lst part of the error msgs;
File “C:\Users\Frank.julia\conda\3\lib\site-packages\notebook\services\kernels\kernelmanager.py”, line 160, in start_kernel
super(MappingKernelManager, self).start_kernel(**kwargs)
File “C:\Users\Frank.julia\conda\3\lib\site-packages\jupyter_client\multikernelmanager.py”, line 110, in start_kernel
km.start_kernel(**kwargs)
File “C:\Users\Frank.julia\conda\3\lib\site-packages\jupyter_client\manager.py”, line 259, in start_kernel
**kw)
File “C:\Users\Frank.julia\conda\3\lib\site-packages\jupyter_client\manager.py”, line 204, in _launch_kernel
return launch_kernel(kernel_cmd, **kw)
File “C:\Users\Frank.julia\conda\3\lib\site-packages\jupyter_client\launcher.py”, line 128, in launch_kernel
proc = Popen(cmd, **kwargs)
File “C:\Users\Frank.julia\conda\3\lib\subprocess.py”, line 709, in init
restore_signals, start_new_session)
File “C:\Users\Frank.julia\conda\3\lib\subprocess.py”, line 997, in _execute_child
startupinfo)
FileNotFoundError: [WinError 2] The system cannot find the file specified


#4

have you tried (in Julia 1.1.0) to do ] build IJulia?


#5

Any time you change the location of Julia (e.g. moving it to a new directory or installing a new version with a different name) you must re-run build IJulia (in the Julia terminal): https://github.com/JuliaLang/IJulia.jl#updating-julia-and-ijulia


#6

we just had the same issue, we solved it by setting JULIA_DEPOT_PATH from bash before building IJulia. If it was set from within Julia by pushing to DEPOT_PATH the kernel could not be found. Cf: https://github.com/JuliaLang/julia/issues/30528#issuecomment-450504366


#7

rebuilding IJulia did not solve the problem


#8

what’s the equivalent solution under Windows?


#9

Sorry, I’m not a windows user so I have no idea.


#10

What is JULIA_DEPOT_PATH supposed to be set to?


#11

What happens if you move your .julia directory out of the way (just change its name) and then reinstall IJulia?


#12

I deleted everything and just installed 1.10 and now things seem to be working