JuMP v0.19 and CPLEX versions


While upgrading to julia 1.1.1 I thought it would be a good time to upgrade to JuMP 0.19. However, I could not add the CPLEX package (the executable and libraries could not be found) because CPLEX12.6 is not one of the specified versions in CPLEX.jl – this seemed to be an issue for some people previously, too. When I tried to grab teh latest CPLEX executable download from IBM I now find that it is not the “academic” version but, rather, the “free” version with much reduced problem size limits.

Would it be incompatible with the latest JuMP+CPLEX.jl to accept version 12.6 of the executable? The academic license version of 12.9 seems to be unavailable from IBM’s website.

Many thanks,
P. Healy

We dropped support for CPLEX < 12.8 because of a change in the CPLEX API. See https://github.com/JuliaOpt/CPLEX.jl#help-i-got-loaderror-unable-to-locate-cplex-installation.

Last time I checked, you could still get an academic instance of CPLEX from IBM. I suggest you follow up with them.

Thanks for the prompt reply. It appears that IBM are reorganizing their academic initiative offerings and this got lost in the shuffle. I have been provided with a workable version of CPLEX 12.9 now.

Thanks again.

@PatrickHealy, I’m running into the same issue. Did you just contact them directly?

Yes. After contacting the Academic Initiative address I was given a person to write to.

So that he doesn’t get deluged I have written to him asking if it is ok to post his name. If you write to me I will give you his name privately. Apologies for the probably unnecessary furtiveness.

Great, thank you!