JuMP Stopped Working Today

Hi, I’ve been using JuMP for a project and it stopped working today after I installed Gurobi. I get ERROR: LoadError: MethodError: no method matching Model(::Type{Gurobi.Optimizer}) when I set the solver to Gurobi, but it is also doing this for Ipopt. I have tried downgrading/upgrading the package versions but the same error keeps occurring. What could be causing this?

Thanks.

Try ] add JuMP@0.21. You must have added another package that forced JuMP to downgrade.

Use a Pkg environment to avoid having incompatible versions of packages: https://julialang.github.io/Pkg.jl/v1/environments/

1 Like

I tried that but it said no changes. My current packages are
[c52e3926] Atom v0.12.21
[2e9cd046] Gurobi v0.8.1
[7073ff75] IJulia v1.21.3
[b6b21f68] Ipopt v0.6.3
[4076af6c] JuMP v0.21.3
[e5e0dc1b] Juno v0.8.3
[91a5bcdd] Plots v1.6.3
[a759f4b9] TimerOutputs v0.5.6
[fdbf4ff8] XLSX v0.7.3

Close Julia and re-start. Everything looks okay. Not sure what the issue is.

I restarted again and now it’s working for whatever reason. Thanks.

1 Like