JuliaBox: Package releases and Plotting problem

juliabox

#1

Hi

I’m not sure where to list this properly, because it started with a plotting problem: using Plots with plotlyjs backend doesn’t seem to work on IJulia anymore.
I tried a few things on my side (getting master, trying to hack it etc.), then started to wonder if maybe the problem is only on my installations. Thus just now I tried from JuliaBox:

using Pkg
Pkg.add("Plots")
Pkg.add("PlotlyJS")
using Plots
plotlyjs()
plot(rand(10))

Give the output:

Updating registry at `/home/jrun/.julia/registries/JuliaPro`
  Updating git-repo `https://pkg.juliacomputing.com/registry/JuliaPro`
 Resolving package versions...
  Updating `~/.julia/Project.toml`
  [91a5bcdd] + Plots v0.20.2
  Updating `~/.julia/Manifest.toml`
  [3da002f7] + ColorTypes v0.7.5
  [5ae59095] + Colors v0.9.4
  [d38c429a] + Contour v0.5.1
  [864edb3b] + DataStructures v0.14.0
  [53c48c17] + FixedPointNumbers v0.5.3
  [28b8d3ca] + GR v0.34.1
  [682c06a0] + JSON v0.19.0
  [442fdcdd] + Measures v0.3.0
  [e1d29d7a] + Missings v0.3.1
  [77ba4419] + NaNMath v0.3.2
  [bac558e1] + OrderedCollections v1.0.1
  [ccf2f8ad] + PlotThemes v0.3.0
  [995b91a9] + PlotUtils v0.5.4
  [91a5bcdd] + Plots v0.20.2
  [3cdcf5f2] + RecipesBase v0.6.0
  [189a3867] + Reexport v0.2.0
  [ae029012] + Requires v0.5.2
  [992d4aef] + Showoff v0.2.1
  [a2af1166] + SortingAlgorithms v0.3.1
  [90137ffa] + StaticArrays v0.8.3
  [2913bbd2] + StatsBase v0.25.0
  [2a0f44e3] + Base64 
  [b99e7846] + BinaryProvider 
  [34da2185] + Compat 
  [864e158e] + CredentialsHandler 
  [ade2ca70] + Dates 
  [8bb1440f] + DelimitedFiles 
  [8ba89e20] + Distributed 
  [cd3eb016] + HTTP 
  [83e8ac13] + IniFile 
  [b77e0a4c] + InteractiveUtils 
  [76f85450] + LibGit2 
  [8f399da3] + Libdl 
  [37e2e46d] + LinearAlgebra 
  [56ddb016] + Logging 
  [d6f4376e] + Markdown 
  [739be429] + MbedTLS 
  [a63ad114] + Mmap 
  [44cfe95a] + Pkg 
  [de0858da] + Printf 
  [3fa0cd96] + REPL 
  [9a3f8284] + Random 
  [ea8e919c] + SHA 
  [9e88b42a] + Serialization 
  [1a1011a3] + SharedArrays 
  [6462fe0b] + Sockets 
  [2f01184e] + SparseArrays 
  [10745b16] + Statistics 
  [4607b0f0] + SuiteSparse 
  [9d418dce] + TOML 
  [8dfed614] + Test 
  [cf7118a7] + UUIDs 
  [4ec0a83e] + Unicode 
 Resolving package versions...
Downloaded from https://pkg.juliacomputing.com/package/f0f68f2c-4968-5e81-91da-67840de0976a/c4d2ec068abac8030609a31e838d6bd891bc29ea.tar.gz
 Installed PlotlyJS ──────────── v0.11.1
Downloaded from https://pkg.juliacomputing.com/package/ffbed154-4ef7-542d-bbb7-c09d3a79fcae/a016e0bfe98a748c4488e2248c2ef4c67d6fdd35.tar.gz
 InstalledDownloaded from https://pkg.juliacomputing.com/package/ffc61752-8dc7-55ee-8c37-f3e9cdd09e70/fb4b57a278d18434eff78bdc2c06238f6ee3c9e7.tar.gz
 DocStringExtensions ─ v0.5.0
 InstalledDownloaded from https://pkg.juliacomputing.com/package/a975b10e-0019-58db-a62f-e48ff68538c9/487feb060cdd5cc152ef4f75b3cb565c0dc4300a.tar.gz
Downloaded from https://pkg.juliacomputing.com/package/a03496cd-edff-5a9b-9e67-9cda94a718b5/e0d6ca3c4ccf9291d12450f7c616912db9ca6b92.tar.gz
Downloaded from https://pkg.juliacomputing.com/package/ad839575-38b3-5650-b840-f874b8c74a25/9b2e31437235eb00c22a979d657136982b01abce.tar.gz
 Mustache ──────────── v0.5.1
 Installed Mux ───────────────── v0.5.3
 Installed PlotlyBase ────────── v0.2.2
 Installed Blink ─────────────── v0.8.0
  Updating `~/.julia/Project.toml`
  [f0f68f2c] + PlotlyJS v0.11.1
  Updating `~/.julia/Manifest.toml`
  [bf4720bc] + AssetRegistry v0.1.0
  [9e28174c] + BinDeps v0.8.10
  [ad839575] + Blink v0.8.0
  [ffbed154] + DocStringExtensions v0.5.0
  [de31a74c] + FunctionalCollections v0.4.0
  [9fb69e20] + Hiccup v0.2.2
  [97c1335a] + JSExpr v0.3.1
  [b964fa9f] + LaTeXStrings v1.0.3
  [50d2b5c4] + Lazy v0.13.1
  [1914dd2f] + MacroTools v0.4.4
  [ffc61752] + Mustache v0.5.1
  [a975b10e] + Mux v0.5.3
  [510215fc] + Observables v0.2.2
  [fa939f87] + Pidfile v1.1.0
  [a03496cd] + PlotlyBase v0.2.2
  [f0f68f2c] + PlotlyJS v0.11.1
  [30578b45] + URIParser v0.4.0
  [0f1e0344] + WebIO v0.3.4
  [104b5d7c] + WebSockets v1.0.3
  [cc8bc4a8] + Widgets v0.4.2
  [7b1f6079] + FileWatching 
  Building Blink ───→ `~/.julia/packages/Blink/KMJt9/deps/build.log`
  Building PlotlyJS → `~/.julia/packages/PlotlyJS/7k06k/deps/build.log`

┌ Info: Precompiling PlotlyJS [f0f68f2c-4968-5e81-91da-67840de0976a]
└ @ Base loading.jl:1186
WARNING: could not import Base.quit into AtomShell
UndefVarError: JupyterPlot not defined

Stacktrace:
 [1] _show(::Base.GenericIOBuffer{Array{UInt8,1}}, ::MIME{Symbol("text/html")}, ::Plots.Plot{Plots.PlotlyJSBackend}) at /home/jrun/.julia/packages/Plots/EJpx2/src/backends/plotlyjs.jl:61
 [2] show(::Base.GenericIOBuffer{Array{UInt8,1}}, ::MIME{Symbol("text/html")}, ::Plots.Plot{Plots.PlotlyJSBackend}) at /home/jrun/.julia/packages/Plots/EJpx2/src/output.jl:201
 [3] #sprint#325(::Nothing, ::Int64, ::Function, ::Function, ::MIME{Symbol("text/html")}, ::Vararg{Any,N} where N) at ./strings/io.jl:101
 [4] sprint(::Function, ::MIME{Symbol("text/html")}, ::Vararg{Any,N} where N) at ./strings/io.jl:97
 [5] display_dict(::Plots.Plot{Plots.PlotlyJSBackend}) at /home/jrun/.julia/packages/Plots/EJpx2/src/init.jl:76
 [6] #invokelatest#1 at ./essentials.jl:686 [inlined]
 [7] invokelatest at ./essentials.jl:685 [inlined]
 [8] execute_request(::ZMQ.Socket, ::IJulia.Msg) at /home/jrun/.julia/packages/IJulia/4VL8h/src/execute_request.jl:197
 [9] #invokelatest#1 at ./essentials.jl:686 [inlined]
 [10] invokelatest at ./essentials.jl:685 [inlined]
 [11] eventloop(::ZMQ.Socket) at /home/jrun/.julia/packages/IJulia/4VL8h/src/eventloop.jl:8
 [12] (::getfield(IJulia, Symbol("##12#15")))() at ./task.jl:259
Pkg.status()
 Status `~/.julia/Project.toml`
  [f0f68f2c] PlotlyJS v0.11.1
  [91a5bcdd] Plots v0.20.2

Thus on the one hand, the plotting problem also seems to exist on the latest release, however what is more confusing is looking at Plots.jl’s github:


The latest release is 0.21.0 and there is 4 releases inbetween 0.20.2 and 0.21.0. Somehow these releases are not trickling through to JuliaBox.
Trying to look further:

Mentions the Last Touched as 1 day ago, but the latest version listed in the versions panel is the same 0.20.1, so JuliaObserver also doesn’t help debug what is the latest actual version released.

Is this this a problem of the Attobot integration on Plots.jl’s github?
Does it imply an additional issue on JuliaObserver in terms of showing random version number’s instead of the latest released versions?
Plus the original Plots issue.