Julia v1.1.0 has been released

I think they need to be rebuilt and recompiled.

1 Like

Vast majority will just work. They will be precompiled again though when importing them.

1 Like

great work! thanks~

Since the 1.0 series of releases will have longer-term support, we do intend to continue backporting bugfixes. In fact, there is already a pull request with backports to make a 1.0.4 release.

Whether to upgrade depends on the risk tolerance of your use of Julia. Long-term support releases are intended to be the ultimate in stability, whereas 1.1 contains minor changes in behavior that were determined not to adversely affect packages. As with most things, there is a trade-off to be made, but the risk of updating to 1.1 should still be quite low.

11 Likes

I just noticed that the binaries for 1.0.2 have been taken off of julialang.org/downloads/. Are these still available somewhere? Edit: Found it.

Unfortunately, 1.0.3 caused major problems with our companies code base that continue in the 1.1 release. This was reported by someone else here, although work today is making me think this is actually larger issue (I’m still working on putting together a simple example of the issues I’ve encountered today).

Has anyone had any success running large distributed jobs since julia 1.0.2?

7 posts were split to a new topic: Are the Julia binaries GPL-free?

I uninstalled Julia 1.0.3 + Juno (on Windows 10), reinstalled them, and updated the Julia packages.

I then run IJulia from the Julia 1.1.0 prompt. If I try to create a new Jupyter notebook, the browser (Firefox) doesn’t find Julia 1.1.0 as a kernel – only Julia 1.0.3.

Do I need to uninstall the packages and re-install them in order for IJulia to find the Julia 1.1.0 kernel?

pkg> build IJulia should do the trick and register the 1.1.0 kernel

3 Likes

Thanks, nilshg – that did the trick.

1 Like

I just updated Julia on my home computer to Julia 1.1.0. After build-ing IJulia, it starts, but when I run a cell (Ctrl+Return), a new cell is not created, and I have to insert it manually.

How do I change IJulia such that new cells are created automatically? Any idea?

Should be Shift-return instead of ctrl-return

1 Like

@BLI, @dpsanders
Just tried in a Jupyter Notebook:
Shift-Return is execute cell and move to next cell
Crtl-Return is execute cell and stay in cell
Alt-Return is execute cell and create new cell below

Thanks… I tend to do these things “automatically” without thinking, and my brain must have decoupled when I was sitting in my recliner with my 55" TV as monitor instead of sitting at my work desk…

juius – thanks for list of possibilities:

  • Ctrl-Return: execute and stay in cell (execute, and stay in Controlled “environment”/cell)
  • Shift+Return: execute and Shift to next cell (create new cell if there is no next cell)
  • Alt+Return: execute, and as an Alternative create new cell and shift to that cell.

I guess I need rules like these to remember things before my brain gets programmed…

Could it be the default?

Discussion in https://github.com/JuliaLang/julia/pull/28631 is relevant

2 Likes

Do you still want bug reports for 1.0.3? For context, I just found a case where it seems that running tests with code coverage on produces different results than with code coverage off on 1.0.3, while 1.1.0 doesn’t display this behavior.

Yes, please do file issues for bugs on the 1.0.x branch—this is the current long term support branch so there will be further bug fix 1.0.x releases.

OK, see https://github.com/JuliaLang/julia/issues/30872.

1 Like

I’ve just noticed, that the checksum files for v1.1.0 are not linked on https://julialang.org/downloads/, only the checksum files for v1.0.3 are linked to.

However, one can download them, if adapting the URL of the v1.0.3 ones, e.g. https://julialang-s3.julialang.org/bin/checksums/julia-1.1.0.sha256

I know this is a stupid question but

Does Julia v1.1.0 works on the Juno Atom editor (on a mac)?