Julia v1.0.4 and v1.1.1 have been released

The Julia developers are pleased to announce the release of Julia versions 1.0.4 and 1.1.1, available for download on https://julialang.org/downloads. These are both patch releases, and as such contain no new features or breaking changes, only bug fixes, documentation updates, and performance improvements.

Note that 1.0 and 1.1 on Travis, AppVeyor (using Appveyor.jl), and Cirrus (using CirrusCI.jl) now refer to 1.0.4 and 1.1.1, respectively.

Julia 1.0.4

This is the fourth patch release in the 1.0 series of releases, the current long-term support branch. Binaries are available for:

  • Windows: 32- and 64-bit
  • macOS
  • Linux: i686, x86-64, ARMv7, AArch64
  • FreeBSD: x86-64

We recommend anyone currently using 1.0.3 (or an earlier 1.0.x release) upgrade to 1.0.4. You can see the list of commits included since 1.0.3 here.

Julia 1.1.1

This is the first patch release in the 1.1 series of releases. Binaries are available for:

  • Windows: 32- and 64-bit
  • macOS
  • Linux: i686, x86-64, AArch64
  • FreeBSD: x86-64

We recommend anyone currently using 1.1.0 to upgrade to 1.1.1. Whether you upgrade to 1.1.1 from a 1.0 release depends on your risk tolerance, though generally speaking it should be quite safe. You can see the list of commits included since 1.1.0 here.

Enjoy!

32 Likes

1.1.1 congratulations!

How will these branches eventually converge? 1.0.X will become 1.1.Y? And what about 1.2?

They won’t really converge; each release branch lives separately in perpetuity.

The 1.0 series has long-term support, so we’ll keep making 1.0.x releases until some hypothetical end of support date far in the future. The 1.1 series does not have long-term support, so we won’t likely make more than a couple 1.1.x releases. Each 1.x that does not have long term support will be effectively superseded by 1.(x+1).

2 Likes

I think we should probably explain the release strategy on the downloads page.

17 Likes

Installing v. 1.1.1? I’ve run v. 1.1.0 for some time:

  • I uninstalled Julia (v. 1.1.0) using the Control Panel
  • Downloaded and installed Julia v. 1.1.1 for 64bit Windows from julialang.org
  • Ran the Package manager to update packages.
  • using IJulia, I have tried to start both notebook() and jupyterlab().
  • In both cases, neither notebook() nor jupyterlab() find the kernel of v. 1.1.1 – only the kernels of previous versions of Julia, including v. 1.1.0 (and v. 0.6.4, etc…)

Do I need to remove all packages, and reinstall everything?

I think you just need to do ]build IJulia to get the new kernel.

4 Likes

Thanks, that solved the problem.

I had the exact same problem (and got the same answer on Slack) which fixed it when I was upgrading to 1.1.0 from 1.0.0. I think it’s time for some documentation in the IJulia package. Maybe I’ll see if I can put together a small pr later today.

I take it back it totally is written there right in the ReadMe already. Maybe it just needs to be more prominent or in an FAQ or something.

1 Like

I am confused to what to install on our computing cluster. I would ideally like to have 1.0.x branch since it has long-term support. But what does this mean for packages? Could it be that I may want to use a package that works with 1.1 but not 1.0? Are package maintainers keeping two “versions” based on what version of Julia is installed?

95% of package releases are compatible with 1.0.

1 Like

Unless absolutely necessary, I would strongly recommend using the latest version. The 1.0.x series is arguably mostly for people who have a lot of existing julia code that they just want to keep running while still getting bug fixes.

4 Likes

For simple packages one can easily support all the way back to 0.7 . If the package lives on github you can easily set up travis to build all the versions you want to support. Also the package metadata defines what it supports. So if you are on an older version of julia it should automatically use the latest version of the package that supports that version.

I’ve been trying to rewrite the FAQ section on that.
Onces that is does we can probably just like to it from the downloads page

When will the Julia version of conda be updated ?

Not really up to us. I would ask on Conda forums. Using the official binaries is strongly recommended and should be very easy to install.

3 Likes

Thanks for your reply !