Julia 1.2 on CentOS: package manager says ERROR: no active project

After installing julia 1.2 by extracting the tar.gz file I can run the julia console but when I enter the package manager console and do add I get ERROR: no active project. Tere’s no prefix (v1.2) in the pm prompt.

Before with julia 0.6 everything worked on the same machine. I also upgraded an ubuntu machine from 0.6 to 1.2 and there everything worked.

I know .julia/evironments and its files were missing; I even scp’d them from my ubuntu machine to this machine and also tried activate . but nothing seems to work.

What to do?

What is the value of DEPOT_PATH?

It’s not set

Did you set JULIA_DEPOT_PATH then? Otherwise DEPOT_PATH should be set to defaults by Julia.

No I didn’t set it. There is no JULIA_DEPOT_PATH env var.

And yet


is an empty array?

I get this


Ok, what about


julia> LOAD_PATH

julia> Base.load_path()



julia> LOAD_PATH
1-element Array{String,1}:

julia> Base.load_path()
1-element Array{String,1}:

Why did you set that load path? I’m guessing the problem is that there is no Project.toml file at that location.

That’s where my sources are

Comparing with my ubuntu machine I see that it’s different there. I’ll try to clear that env load path and see if that fixes it.

Sources of what? Packages? Sounds like you are using LOAD_PATH to something it is not meant for.

No my application source code.

For an individual package it should work if you give it the path to the root, probably just remove the trailing src/ would make it work.

unsetting the JULIA_LOAD_PATH env var fixed it!