I’m using julia v0.5, and while precompiling one of my packages I ran into a JLD.jl issue – one that seems to have been fixed months ago. I checked the installed version, and it was only v0.5.5 (the current latest version is v0.6.9). I tried
Pkg.free, then removing and re-adding, but it kept installing v0.5.5. (Interestingly,
Pkg.free gives me the message:
INFO: Downgrading JLD: v0.6.9 => v0.5.5.)
grep "JLD" ~/.julia/v0.5/*/REQUIRE, but didn’t find any restrictive requirements in my installed packages. It does let me
Pkg.pin("JLD",v"0.6.9"), and it upgrades several packages in the process. Keeping it pinned doesn’t really seem tenable to me, so can someone help me understand what’s going on? Thanks.