Issue with PlotsRecipes dependency

#1

Hi

I’ve been having issues installing various packages which have PlotsRecipes as a dependency. For this topic I took the code from my error when trying to install ProfileView.

At first I thought the package deprecation is probably related the “Package compatibility caps”

However, I tried it on two other machines and not received the same error which leads me to believe this is specific to my machine. (Also I don’t see any other issues here mentioning PlotRecipes)

All three machines are on the Version 1.0.0 (2018-08-08).

Could there be a setting on my end causing this? I saw the recommendation in “Package compatibility caps”, but for someone like me altering the code like that seems a bit intimidating. Since this issue is limited to only 1 of my machines, I assume that is not the issue though.

(v1.0) pkg> add ProfileView
  Updating registry at `C:\Users\cth\.julia\registries\General`
  Updating git-repo `https://github.com/JuliaRegistries/General.git`
 Resolving package versions...
ERROR: Unsatisfiable requirements detected for package PlotRecipes [0e44f1d2]:
 PlotRecipes [0e44f1d2] log:
 ├─possible versions are: [0.0.1-0.0.6, 0.1.0, 0.2.0, 0.3.0] or uninstalled
 ├─restricted to versions * by an explicit requirement, leaving only versions [0.0.1-0.0.6, 0.1.0, 0.2.0, 0.3.0]
 └─restricted by julia compatibility requirements to versions: uninstalled — no versions left

FYI, the error if I try to install PlotRecipes directly is identical.

Thanks!

#2

For reference should someone encounter this error in the future, I solved the issue by removing PlotRecipes.
i.e.

remove PlotRecipes

I’m not really sure why this solved the issue. If someone can explain, it would be helpful to know for future reference.

Thanks!

#3

I tried removing it but I just get the message

‘PlotRecipes’ not in project, ignoring
no changes.

I’ve tried thousands of things but still cant figure it out.
Im a newcomer to the language btw, and im using Juno