Installing ROS.jl error

Hi, I’m trying to install ROS.jl.
After adding the package using pkg> add ROS and calling using ROS, I get the following error:

julia> using ROS
[ Info: Precompiling ROS [a492bfac-16cc-4d50-a8b6-f03352b6b563]
[ Info: Skipping precompilation since __precompile__(false). Importing ROS [a492bfac-16cc-4d50-a8b6-f03352b6b563].
[ Info: Precompiling Cxx [a0b5b9ef-44b7-5148-a2d1-f6db19f3c3d2]
ERROR: LoadError: could not load library "C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\..\deps\usr\bin\libcxxffi"
The specified procedure could not be found.
  [1] dlopen(s::String, flags::UInt32; throw_error::Bool)
    @ Base.Libc.Libdl .\libdl.jl:117
  [2] dlopen
    @ .\libdl.jl:117 [inlined]
  [3] init_libcxxffi()
    @ Cxx.CxxCore C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\initialization.jl:23
  [4] top-level scope
    @ C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\initialization.jl:25
  [5] include(mod::Module, _path::String)
    @ Base .\Base.jl:418
  [6] include(x::String)
    @ Cxx.CxxCore C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\Cxx.jl:144
  [7] top-level scope
    @ C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\Cxx.jl:170
  [8] include
    @ .\Base.jl:418 [inlined]
  [9] include_package_for_output(pkg::Base.PkgId, input::String, depot_path::Vector{String}, dl_load_path::Vector{String}, load_path::Vector{String}, concrete_deps::Vector{Pair{Base.PkgId, UInt64}}, source::String)
    @ Base .\loading.jl:1318
 [10] top-level scope
    @ none:1
 [11] eval
    @ .\boot.jl:373 [inlined]
 [12] eval(x::Expr)
    @ Base.MainInclude .\client.jl:453
 [13] top-level scope
    @ none:1
in expression starting at C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\initialization.jl:25
in expression starting at C:\Users\kedel\.julia\packages\Cxx\1RaOv\src\Cxx.jl:142
ERROR: LoadError: Failed to precompile Cxx [a0b5b9ef-44b7-5148-a2d1-f6db19f3c3d2] to C:\Users\kedel\.julia\compiled\v1.7\Cxx\jl_4E50.tmp.
  [1] error(s::String)
    @ Base .\error.jl:33
  [2] compilecache(pkg::Base.PkgId, path::String, internal_stderr::IO, internal_stdout::IO, ignore_loaded_modules::Bool)
    @ Base .\loading.jl:1466
  [3] compilecache(pkg::Base.PkgId, path::String)
    @ Base .\loading.jl:1410
  [4] _require(pkg::Base.PkgId)
    @ Base .\loading.jl:1120
  [5] require(uuidkey::Base.PkgId)
    @ Base .\loading.jl:1013
  [6] require(into::Module, mod::Symbol)
    @ Base .\loading.jl:997
  [7] include
    @ .\Base.jl:418 [inlined]
  [8] _require(pkg::Base.PkgId)
    @ Base .\loading.jl:1149
  [9] require(uuidkey::Base.PkgId)
    @ Base .\loading.jl:1013
 [10] require(into::Module, mod::Symbol)
    @ Base .\loading.jl:997
 [11] eval
    @ .\boot.jl:373 [inlined]
 [12] eval
    @ .\Base.jl:68 [inlined]
 [13] repleval(m::Module, code::Expr, #unused#::String)
    @ VSCodeServer c:\Users\kedel\.vscode\extensions\julialang.language-julia-1.5.9\scripts\packages\VSCodeServer\src\repl.jl:157
 [14] (::VSCodeServer.var"#71#73"{Module, Expr, REPL.LineEditREPL, REPL.LineEdit.Prompt})()
    @ VSCodeServer c:\Users\kedel\.vscode\extensions\julialang.language-julia-1.5.9\scripts\packages\VSCodeServer\src\repl.jl:123
 [15] with_logstate(f::Function, logstate::Any)
    @ Base.CoreLogging .\logging.jl:511
 [16] with_logger
    @ .\logging.jl:623 [inlined]
 [17] (::VSCodeServer.var"#70#72"{Module, Expr, REPL.LineEditREPL, REPL.LineEdit.Prompt})()
    @ VSCodeServer c:\Users\kedel\.vscode\extensions\julialang.language-julia-1.5.9\scripts\packages\VSCodeServer\src\repl.jl:124
 [18] #invokelatest#2
    @ .\essentials.jl:716 [inlined]
 [19] invokelatest(::Any)
    @ Base .\essentials.jl:714
 [20] macro expansion
    @ c:\Users\kedel\.vscode\extensions\julialang.language-julia-1.5.9\scripts\packages\VSCodeServer\src\eval.jl:34 [inlined]
 [21] (::VSCodeServer.var"#55#56")()
    @ VSCodeServer .\task.jl:423
in expression starting at C:\Users\kedel\.julia\packages\ROS\AQF9s\src\ROS.jl:2

I tried to install the Cxx.jl package separately and then build the ROS.jl again but I still get the same error.

can someone help me?
thanks in ahead

Which Julia version do you use?

I think Cxx.jl does not work with Julia 1.7.

Please, note that Cxx.jl only works (out of the box) currently with Julia 1.1.x to 1.3.x, i.e. with no currently supported Julia, while those versions can still be downloaded at

So just install Julia 1.3 …

You can use different versions of Julia per project with the help of GitHub - johnnychen94/ A cross-platform installer for the Julia programming language

thank you for the quick reply, I do use julia 1.7.
I’ll change to 1.3 as you advised.

I don’t think you can use Cxx.jl on Windows regardless of the Julia version.