Installing binaries behind zscaler

#1

When trying install package Julia tries to download packages. e.g when installing DataFrames.jl

it tries this

But it fails with

(v1.0) pkg> build CodecZlib
Building CodecZlib → C:\Users\L098905\.julia\packages\CodecZlib\DAjXH\deps\bu ild.log
┌ Error: Error building CodecZlib:
│ [ Info: Downloading https://github.com/bicycle1885/ZlibBuilder/releases/downlo
ad/v1.0.3/Zlib.v1.2.11.x86_64-w64-mingw32.tar.gz to C:\Users\L098905.julia\pack
ages\CodecZlib\DAjXH\deps\usr\downloads\Zlib.v1.2.11.x86_64-w64-mingw32.tar.gz…
.
│ ERROR: LoadError: Could not download https://github.com/bicycle1885/ZlibBuilde
r/releases/download/v1.0.3/Zlib.v1.2.11.x86_64-w64-mingw32.tar.gz to C:\Users\L0
98905.julia\packages\CodecZlib\DAjXH\deps\usr\downloads\Zlib.v1.2.11.x86_64-w64
-mingw32.tar.gz:
│ ErrorException("")
│ Stacktrace:
│ [1] error(::String) at .\error.jl:33
│ [2] #download#93(::Bool, ::Function, ::String, ::String) at C:\Users\L098905
.julia\packages\BinaryProvider\4F5Hq\src\PlatformEngines.jl:498
│ [3] #download at .\none:0 [inlined]
│ [4] #download_verify#94(::Bool, ::Bool, ::Bool, ::Function, ::String, ::Strin
g, ::String) at C:\Users\L098905.julia\packages\BinaryProvider\4F5Hq\src\Platfo
rmEngines.jl:567
│ [5] #download_verify at .\none:0 [inlined]
│ [6] #install#133(::Prefix, ::String, ::Bool, ::Bool, ::Bool, ::Function, ::St
ring, ::String) at C:\Users\L098905.julia\packages\BinaryProvider\4F5Hq\src\Pre
fix.jl:314
│ [7] (::getfield(BinaryProvider, Symbol("#kw##install")))(::NamedTuple{(:prefi
x, :force, :verbose),Tuple{Prefix,Bool,Bool}}, ::typeof(install), ::String, ::St
ring) at .\none:0
│ [8] top-level scope at C:\Users\L098905.julia\packages\CodecZlib\DAjXH\deps
build.jl:89
│ [9] include at .\boot.jl:317 [inlined]
│ [10] include_relative(::Module, ::String) at .\loading.jl:1044
│ [11] include(::Module, ::String) at .\sysimg.jl:29
│ [12] include(::String) at .\client.jl:392
│ [13] top-level scope at none:0
│ in expression starting at C:\Users\L098905.julia\packages\CodecZlib\DAjXH\dep
s\build.jl:78
│ Exception calling “DownloadFile” with “2” argument(s): “The remote server
│ returned an error: (403) Forbidden.”
│ At line:5 char:1
│ + $webclient.DownloadFile("https://github.com/bicycle1885/ZlibBuilder/releases
/
│ dow …
│ + ~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~~
~
│ ~~~
│ + CategoryInfo : NotSpecified: (:slight_smile: , MethodInvocationException
│ + FullyQualifiedErrorId : WebException

└ @ Pkg.Operations C:\cygwin\home\Administrator\buildbot\worker\package_win64\bu
ild\usr\share\julia\stdlib\v1.0\Pkg\src\Operations.jl:1097

but when I try to download the files from Chrome this message shows and after a couple of sconds I can download

The file you attempted to download is being analyzed for your protection. It is not blocked. The analysis can take up to 10 minutes, depending on the size and type of the file.

If safe, your file downloads automatically.

If unsafe, the file will be blocked.
You tried to download:

https://github-production-release-asset-2e65be.s3.amazonaws.com/126450947/1261a800-daf6-11…

Your organization has selected Zscaler to protect you from internet threats.

Does anyone have any idea how to get around this?

0 Likes

#2

So when I’ve faced issues like this I’ve generally downloaded the file in question into the deps folder of the package myself and ran the build script, which I suppose is the lowest tech solution possible but gets the job done.

I also believe I’ve seen solutions around modifying the time the build script waits for the file to be available but haven’t tried this myself.

1 Like

#3

Hi. We have a zscaler proxy where I work. I just configure my http proxy like this

git config --global http.proxy http://NN.NN.NN.NN:80

git config --global https.proxy https://NN.NN.NN.NN:443

On windows 10 with the edge browser I can download this file
https://github.com/bicycle1885/ZlibBuilder/releases/download/v1.0.3/Zlib.v1.2.11.i686-w64-mingw32.tar.gz

Sorry that I cannot help you - there is probably an option in zscaler which does this security scan

1 Like

#4

Ok. Where is the deps folder?

0 Likes

#5

Sorry I spoke to soon and on the phone so didn’t check properly - I meant the downloads folder the location of which is in your stack trace, it should be

C:\Users\L0 98905.julia\packages\CodecZlib\DAjXH\deps\usr\downloads\Zlib.v1.2.11.x86_64-w64

If you just put the file there and build the package it should work

1 Like