Installing an unregistered package

Hi all,

So I have been trying to install the this following package:

Every time I do so either using “add” or “dev”, the package does get installed but only the original version 0.1.0 and not the updated 0.1.1, which is what I am after. Can anyone please guide me how to get it done?

1 Like

The main branch of that repository is still at version 0.1.0. To get the NewNet branch from your link, you need to specify it, i.e.,

pkg> add

Okay, thanks so much, it worked!

Now when I use “using QuNet”, it works.

But now I am stuck on something else, I need to access the package folder (it’s in ~/.julia folder somewhere in my machine if I am not wrong?) but I can’t seem to find it anywhere. I run macOS.
Could you please help? Thanks in advance!

Use dev and it will go into .julia/dev/QuNet.


For me, that doesn’t work:

pkg> dev
ERROR: rev argument not supported by `develop`; consider using `add` instead

Instead, you can:

  • Either git clone the repo to any place you want, check out the NewNet branch, and
    pkg> dev path/to/my/clone
  • Or use dev without the branch, and change it afterwards (using the shell, either from wihin Julia or from a separate terminal window):
    pkg> dev
    shell> cd ~/.julia/dev/QuNet
    shell> git checkout NewNet
    Branch 'NewNet' set up to track remote branch 'NewNet' from 'origin'.
    Switched to a new branch 'NewNet'

Oh yeah, forgot that, so you would just do dev and check out that branch in the resulting git repo.