Include error

Hey guys I started using Julia today to apply in some exercises. I’ve tried to use the include function and I’m getting this error:

Can anyone help me with understanding what I am doing wrong? I thought that since I’m working on the same directory the dataset is in, I just needed to use the include function and it would all right.

The problem is not the include function, it is the content of the file you try to include. If you read the stacktrace you see that it complains about the first line of your file, so would be helpful if you could post that too.

Here are some examples where you get that error message though, so maybe look for something like this:

julia> {}
ERROR: syntax: { } vector syntax is discontinued around REPL[2]:1
 [1] top-level scope at REPL[2]:1

julia> {1, 2, 3}
ERROR: syntax: { } vector syntax is discontinued around REPL[3]:1
 [1] top-level scope at REPL[3]:100

Hi, I am having the same issue, using Julia 1.7.
No matter the file, the include always throw the vector syntax error. Any idea??

Even if the file has no {} inside itself?

Thanks for your quick reply.
I found the file saved from Jupyter contains the {} in JSON format.
When I use another editor, it works.

Sorry for bothering you.

Hi there,

Could you explain more how do you fixed it? I’m having the same problem