Import the Pkgs already installed on another PC

julia> ENV
Base.EnvDict with 39 entries:
“=::” => “::\”
“ALLUSERSPROFILE” => “C:\ProgramData”
“APPDATA” => “C:\Users\hermesr\AppData\Roaming”
“CommonProgramFiles” => “C:\Program Files\Common Files”
“COMPUTERNAME” => “HERMES”
“ComSpec” => “C:\WINDOWS\system32\cmd.exe”
“DEFLOGDIR” => “C:\ProgramData\McAfee\Endpoint Security\Logs”

“EQ_LIBRARY_PATH” => "c:\users\hermesr\gcc\i686-pc-mingw32\lib;c:.

“FP_NO_HOST_CHECK” => “NO”
“HOMEDRIVE” => “Z:”
“HOMEPATH” => “\”
“HOMESHARE” => “\\ecpfs\users\hermesr.ELECTRA_CON”
“LOCALAPPDATA” => “C:\Users\hermesr\AppData\Local”
“LOGONSERVER” => “\\DCECP01”
“NUMBER_OF_PROCESSORS” => “4”
“OPENBLAS_MAIN_FREE” => “1”
“OS” => “Windows_NT”
“Path” => "C:\Program Files\ImageMagick-7.0.7-Q16;C:\Pro.

“PATHEXT” => ".COM;.EXE;.BAT;.CMD;.VBS;.VBE;.JS;.JSE;.WSF;.WSH.

“PROCESSOR_ARCHITECTURE” => “x86”
? => ?

@HerAdri this rather old writeup should help.
Troubleshooting libgit2
And this
https://www.freecodecamp.org/forum/t/git-behind-a-proxy-server/13187

git config --global http.proxy http://hemes:password@proxy05.ecp.elc:8080

git config --global https.proxy https://hemes:password@proxy05.ecp.elc:8080
I think you opnly have to set the http proxy

If this does not work we may have to set the HTTP_PROXY environment variable

Sorry for hijacking the thread, I asked a few days ago at the Slack #helpdesk but to no avail - @johnh I’m having related issues, maybe you have an idea:

I’m behind a corporate firewall as well but regular package installations actually work fine, my problem is with those packages that rely on shared libraries. As an example, I fail to precompile DataFrames, as it requires building CodecZlib, which errors out with a could not download https://github... to C:\Users\... error. Any idea what is going wrong here?

(would have caught you at the Julia Hackathon last months if I’d known you’re an expert on corporate proxy issues!)

Perhaps you can debug this using a command line utility like wget or curl. Specify the URL, and see if the proxy works, ask for verbose output (eg --verbose for wget).

Hmm… interestingly when trying to simply wget the General.git from GitHub I get Access Denied ... blocked by SurfProtection, which is a bit odd given that pkg seems to interact with GitHub just fine for simply adding packages which don’t attempt to install further dependencies.

The .gitconfig file mentioned in:
Troubleshooting libgit2
I can not find it in my system.

I have only updated and made:

git config --global http.proxy http://hemes:password@proxy05.ecp.elc:8080

git config --global https.proxy https://hemes:password@proxy05.ecp.elc:8080

And I get the following alerts:

               _
   _       _ _(_)_     |  Documentation: https://docs.julialang.org
  (_)     | (_) (_)    |
   _ _   _| |_  __ _   |  Type "?" for help, "]?" for Pkg help.
  | | | | | | |/ _` |  |
  | | |_| | | | (_| |  |  Version 1.0.1 (2018-09-29)
 _/ |\__'_|_|_|\__'_|  |  Official https://julialang.org/ release
|__/                   |

julia> using Pkg

julia> Pkg.add("IJulia")
   Cloning default registries into C:\Users\hermesr\.julia\registries
   Cloning registry General from "https://github.com/JuliaRegistries/General.git
"
**ERROR: failed to clone from https://github.com/JuliaRegistries/General.git, erro**
**r: GitError(Code:ERROR, Class:OS, failed to connect to github.com: )**
Stacktrace:
 [1] pkgerror(::String) at C:\cygwin\home\Administrator\buildbot\worker\package_
win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:120
 [2] #clone#2(::String, ::Base.Iterators.Pairs{Symbol,LibGit2.CachedCredentials,
Tuple{Symbol},NamedTuple{(:credentials,),Tuple{LibGit2.CachedCredentials}}}, ::F
unction, ::String, ::String) at C:\cygwin\home\Administrator\buildbot\worker\pac
kage_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\GitTools.jl:107
 [3] (::getfield(Pkg.Types, Symbol("##51#55")))(::LibGit2.CachedCredentials) at
.\none:0
 [4] shred!(::getfield(Pkg.Types, Symbol("##51#55")), ::LibGit2.CachedCredential
s) at .\secretbuffer.jl:184
 [5] #registries#50(::Bool, ::Function) at C:\cygwin\home\Administrator\buildbot
\worker\package_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:929
 [6] registries at C:\cygwin\home\Administrator\buildbot\worker\package_win32\bu
ild\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:913 [inlined]
 [7] macro expansion at .\logging.jl:307 [inlined]
 [8] update_registry(::Pkg.Types.Context) at C:\cygwin\home\Administrator\buildb
ot\worker\package_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:97
 [9] #handle_repos_add!#32(::Bool, ::Nothing, ::Function, ::Pkg.Types.Context, :
:Array{Pkg.Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker
\package_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\Types.jl:607
 [10] #handle_repos_add! at .\none:0 [inlined]
 [11] #add_or_develop#13(::Symbol, ::Bool, ::Base.Iterators.Pairs{Union{},Union{
},Tuple{},NamedTuple{(),Tuple{}}}, ::Function, ::Pkg.Types.Context, ::Array{Pkg.
Types.PackageSpec,1}) at C:\cygwin\home\Administrator\buildbot\worker\package_wi
n32\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:54
 [12] #add_or_develop at .\none:0 [inlined]
 [13] #add_or_develop#12 at C:\cygwin\home\Administrator\buildbot\worker\package
_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:29 [inlined]
 [14] #add_or_develop at .\none:0 [inlined]
 [15] #add_or_develop#11 at C:\cygwin\home\Administrator\buildbot\worker\package
_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:28 [inlined]
 [16] #add_or_develop at .\none:0 [inlined]
 [17] #add_or_develop#10 at C:\cygwin\home\Administrator\buildbot\worker\package
_win32\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:27 [inlined]
 [18] #add_or_develop at .\none:0 [inlined]
 [19] #add#18 at C:\cygwin\home\Administrator\buildbot\worker\package_win32\buil
d\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:69 [inlined]
 [20] add(::String) at C:\cygwin\home\Administrator\buildbot\worker\package_win3
2\build\usr\share\julia\stdlib\v1.0\Pkg\src\API.jl:69
 [21] top-level scope at none:0

julia>

Which of the following lines is correct:

git config --global url."https://".insteadOf git://       
git config --global url."https://github.com/".insteadOf git://github.com/  
git config --global url."git@github.com:".insteadOf "https://github.com/"

Gracias

This is a Windows system. I Also use Windows with Julia.
I may have got this wrong, but when I open Powershell and type which git I get
PS C:\Users\hearn> which git
/cmd/git

I have installed Git for Windows https://gitforwindows.org/

ALso what happensw in Powershell when you run the command ping github.com
I think we need to stop looking at Julia and get a git clone working on the command line or in Git Bash for Windows. Then we will get Julia working.

Okay, I’ll focus on Git. Is already installed.
The first step would be to run the following line of code: ping github.com?
I will need your guidance.

this is the result:

hermesr@hermes MINGW32 ~
$ ping github.com

Pinging github.com [192.30.253.113] with 32 bytes of data:
Reply from 192.30.253.113: bytes=32 time=138ms TTL=49
Reply from 192.30.253.113: bytes=32 time=137ms TTL=49
Reply from 192.30.253.113: bytes=32 time=145ms TTL=49
Reply from 192.30.253.113: bytes=32 time=137ms TTL=49

Ping statistics for 192.30.253.113:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),
Approximate round trip times in milli-seconds:
    Minimum = 137ms, Maximum = 145ms, Average = 139ms

hermesr@hermes MINGW32 ~
$

Please now try

git clone https://github.com/JuliaRegistries/General.git

Not good result:

hermesr@hermes MINGW32 ~
$ git clone https://github.com/JuliaRegistries/General.git
Cloning into 'General'...
ssh: connect to host github.com port 22: Connection timed out
fatal: Could not read from remote repository.

Please make sure you have the correct access rights
and the repository exists.

hermesr@hermes MINGW32 ~
$

Does this setting help
git config --global url.“https://github.com/

Also please sent the result of git config --list
But please, please edit your password to read password or something.

git config --list


hermesr@hermes MINGW32 ~
$ git config --list
core.symlinks=false
core.autocrlf=true
core.fscache=true
color.diff=auto
color.status=auto
color.branch=auto
color.interactive=true
help.format=html
rebase.autosquash=true
http.sslbackend=schannel
diff.astextplain.textconv=astextplain
filter.lfs.clean=git-lfs clean -- %f
filter.lfs.smudge=git-lfs smudge -- %f
filter.lfs.process=git-lfs filter-process
filter.lfs.required=true
pack.packsizelimit=2g
credential.helper=manager
rebase.usebuiltin=true
stash.usebuiltin=true
core.editor=nano.exe
url.https://github.com/.insteadof=git://github.com/
http.sslcainfo=C:/Users/ngudat/ca-bundle.crt
http.proxy=http://hermesr:hrY424854@10.200.1.32:8080
url.https://.insteadof=git://
https.proxy=http://hermesr:hrY424854@10.200.1.32:8080
url.git@github.com:.insteadof=https://github.com/
push.default=current

hermesr@hermes MINGW32 ~
$

hermesr@hermes MINGW32 ~
$ git config --global url.“https://github.com/”
error: invalid key: url.“https://github.com/”

Absolutely my fault. Try
git config --global url.“https://github.com”.insteadOf git://github.com

hermesr@hermes MINGW32 ~
$ git config --global url.“https://github.com”
error: invalid key: url.“https://github.com”

Without quotes in the address I do not get answers. Only the sign of the system!

hermesr@hermes MINGW32 ~
$ git config --global url.https://github.com

hermesr@hermes MINGW32 ~
$

Ok?

@heradri This s my fault. I am not quoting the code line correctly.
I am simply cutting and pasting from this article:

Please do not get frustrated. We will get this issue fixed.

It is very nice of you to give help with this, but as I suggested above, the organization imposing these (network) restrictions presumably has some form of IT support, which should be capable of resolving these issues very quickly. Debugging this by copy-pasting input and output from a terminal is perhaps the least efficient method. I suppose that @heradri would probably be better served by calling IT, and either resolving this or narrowing it down to a bug.

1 Like

:grinning:
Solved the problem:
I acquired a TP-LINK-TL-WN725N-Nano-USB-Wireless-Adapter-V2-2-Wi-Fi-150Mbps.
I connect to an external wifi, charge the packages that are necessary and return to the abitual network.
I would just like to know how to connect to the portable hostpot of my cell phone.
Thank you