I can't add the package DataFrames to v"0.7.0-DEV.3182" compiled as nonGPL


#1

Hello,

When I tried to add the package DataFrames to Julia v"0.7.0-DEV.3182" compiled as nonGPL I got many warnings and errors in binaries.jl, dependencies.jl and bindeps.jl. To solve this I used
"Nothing" instead of “Void”, and
"MakeTargets(target::Vector{S} … where S <: AbstractString …" instead of “MakeTargets{S <: AbstractString} (target::Vector{S} …” without quotes. And some other correction which I don’t remember.

Right now I get the error: “ERROR: LoadError: LoadError: syntax: unexpected “,”” from dependencies.jl.
Related code line of dependencies.jl is: ccall(:jl_read_sonames, ,())

Is it because of package manager is not consistent with ver 7.0?

Or is it related with nonGPL compilation? I mean is there some GPL dependencies for package manager or DataFrames on Julia side?

PS: I used cygwin64 on win10 64 home


#2

I don’t think that is an issue with non-GPL. Its just that most/many/some packages are not compatible with master. And things are regularly changing on master, such that it will not be guaranteed to work tomorrow, even if it worked today.


#3

You are right. It worked with version 0.6.2.