How to remove and change the default project

I installed JuliaPro with version 1.1.0. (on Windows). After opening Atom and starting Julia in the REPL I switch to the pkg-mode. What I see is the prompt:

(ProjA) pkg>

Now the issue is that “ProjA” does not exist anymore (nor any directory with this name). I do not know where this reference to “ProjA” comes from and I want to get rid of it. I tried several things without success.

What I want is that the name of the current project-folder which is “ProjB.jl” with path “C:\Users\Home\Projects\ProjB.jl” becomes the default project for Julia and that the ghost-project
“ProjA” is eliminated forever.

How to proceed?

(P.S.: What I would wish for is a mechanism like it exists for other programming environments: Just to click on the file Project.toml and Juno opens this project and sets it up as the default project. Or can this be installed easily?)

The solution:

There is an environment variable JULIA_PROJECT which was the path to ProjA. But it was not an existing path!

I suggest that anyone who uses this variable (like JuliaPro or VSCode) first checks if it points to something existing and ignores it otherwise! This is currently not the case.

I’m struggling with the same problem (on Julia 1.5.2). This issue also means whenever I type Pkg.activate() it automatically activates this default project which I want to change back to the original .julia\environments\v1.5\Project.toml

I’m trying to figure out how Julia actually sets the default project. I figured out it sets a Base.HOME_PROJECT[] which it uses in Base.init_load_path(). There it’ll look for Base.current_project() which happens to be my latest developed package, i.e. ProjA in the above example. Base.current_project() just calls pwd().

I can set Base.HOME_PROJECT[] in my startup.jl file, but that doesn’t seem ideal. I want to know how I return to the default behavior of automatically using the .julia\environments\v1.5\Project.toml

I guess I somehow have to change the default pwd() path upon Julia initialization? How can I do that?

Did you customize the environment variable (ie outside Julia) JULIA_PROJECT by any chance? See

Ok it was only happening in VSCode. Somehow I had set my environment wrong there. It could be fixed by clicking the Julia env: MyPackage and setting it back to Julia env: v1.5

It’s in the bottom left corner with all the other notifications for me:
image