How to deal with a Nullable DataFrame?

I have a pretty huge csv file that contains missing values. In this case, the data of my dataframe becomes Nullable types. I have tried to apply the operation :

df = unique!(df[:city]) 
LoadError: e[91mMethodError: no method matching unique!(::NullableArrays.NullableArray{WeakRefString{UInt8},1})e[0m

and i got a message error. I also have tried to apply the function get.(df) but it seems not work neither.
How can I even make this operation and others one with a nullable dataframe ?
I have been using JunoPro and I cannot update to new julia version yet.
Thanks for your help.

NullableArray has been deprecated for a long time. You should really migrate to missing, which exists even on Julia 0.6 (but it is slow) via the Missings.jl package.

1 Like

Thanks for your answer! I just cannot see how to combine Missings.jl package with the action of reading my csv file .
Julia convert my dataframe in Nullable just because I have missing values. I have not decided to use Nullable, that’s Julia that automatically do that.
I have not found the way to use Missing at the moment of reading my csv file.
Could you help me with that ?
Thanks !

Sorry, but I don’t remember how things worked exactly on Julia 0.6. You’d really better upgrade to 0.7.