Help! Plots not loading

I’m having trouble with the GR backend for Plots

 using Plots
[ Info: Precompiling Plots [91a5bcdd-55d7-5caf-9e0b-520d859cae80]
Your GR installation is incomplete. Rerun build step for GR package.
ERROR: LoadError: LoadError: InitError: Evaluation into the closed module `GR` breaks incremental compilation because the side effects will not be permanent. This is likely due to some other module mutating `GR` with `eval` during precompilation - don't do this.

I tried"GR")

Start a new project and see if it works in a fresh environment?

Is that done using ```

It wouldn't stop indexing that so I changed it, and now Plots won't work, and it still won't stop indexing.

How do I restore the default?

I tried creating a new file, and restarting VS Code, I’m not sure I know what starting a project is.

  1. Make a new folder with
julia> mkdir("test")
  1. Go into that directory
julia> cd("test")
  1. Activate the project
julia> import Pkg; Pkg.activate(".")

Then add Plots and see if it works.


I didn’t write Pkg.activate("Plots"). I wrote Pkg.activate("."). Please read the instructions

It won’t recognize makedir, and when I tried to change to an existing directory


it says ERROR: syntax: invalid escape sequence

apologies, i mean to write mkdir. It’s fixed.

You need to use raw"filepath\with\backslashes for working with file paths on windows.

No! Still Broken!

ERROR: syntax: “/” is not a unary operator

What version of Julia are you on?

1.5.2 I’m downloading 1.5.3 now

I should have v1.5.3 set up.

I did that still get the same error:

You should ] build Plots again. But I don’t really know how to help beyond that.

1 Like“Plots”) ?

1 Like

It’s building GR, and that’s what was giving trouble, so that should be a good sign.