GLMakie complains about missing OpenGl, which is there

This might be a OS-problem (fedora 30), but I couldn’t find useful info elsewhere, so I post the problem here.
build GLMakie issues an Error:

(v1.2) pkg> build GLMakie
     Building Conda ───────────→ `~/.julia/packages/Conda/kLXeC/deps/build.log`
     Building FFTW ────────────→ `~/.julia/packages/FFTW/2okGQ/deps/build.log`
     Building SpecialFunctions → `~/.julia/packages/SpecialFunctions/fvheQ/deps/build.log`
     Building FreeType ────────→ `~/.julia/packages/FreeType/2dE5w/deps/build.log`
     Building ImageMagick ─────→ `~/.julia/packages/ImageMagick/vMfoS/deps/build.log`
     Building FFMPEG ──────────→ `~/.julia/packages/FFMPEG/bkWgb/deps/build.log`
     Building CMake ───────────→ `~/.julia/packages/CMake/nSK2r/deps/build.log`
     Building GLFW ────────────→ `~/.julia/packages/GLFW/e257h/deps/build.log`
     Building GLMakie ─────────→ `~/.julia/packages/GLMakie/5wmnA/deps/build.log`
   ┌ Error: Error building `GLMakie`: 
   │ libGL error: MESA-LOADER: failed to open nouveau (search paths /usr/lib64/dri)
   │ libGL error: failed to load driver: nouveau
   │ libGL error: MESA-LOADER: failed to open swrast (search paths /usr/lib64/dri)
   │ libGL error: failed to load driver: swrast
   │ init error of GLFW
   │ ERROR: LoadError: OpenGL/GLFW wasn't installed correctly. This likely means,
   │ you don't have an OpenGL capable Graphic Card,
   │ you don't have the newest video driver installed,
   │ or the GLFW build failed.

The content of /usr/lib64/dri seems to be ok:

ls /usr/lib64/dri/*
/usr/lib64/dri/i915_dri.so           /usr/lib64/dri/r600_dri.so
/usr/lib64/dri/i965_dri.so           /usr/lib64/dri/r600_drv_video.so
/usr/lib64/dri/kms_swrast_dri.so     /usr/lib64/dri/radeon_dri.so
/usr/lib64/dri/nouveau_dri.so        /usr/lib64/dri/radeonsi_dri.so
/usr/lib64/dri/nouveau_drv_video.so  /usr/lib64/dri/radeonsi_drv_video.so
/usr/lib64/dri/nouveau_vieux_dri.so  /usr/lib64/dri/swrast_dri.so
/usr/lib64/dri/r200_dri.so           /usr/lib64/dri/virtio_gpu_dri.so
/usr/lib64/dri/r300_dri.so           /usr/lib64/dri/vmwgfx_dri.so

glxinfo tells me:

   .
   .
   .
   Extended renderer info (GLX_MESA_query_renderer):
    Vendor: nouveau (0x10de)
    Device: NVA8 (0xa74)
    Version: 19.1.7
    Accelerated: yes
    Video memory: 496MB
    Unified memory: no
    Preferred profile: core (0x1)
    Max core profile version: 3.3
    Max compat profile version: 3.3
    Max GLES1 profile version: 1.1
    Max GLES[23] profile version: 3.0
    .
    .
    .
    OpenGL version string: 3.3 (Compatibility Profile) Mesa 19.1.7
    .
    .
    .

Thanks for hints/comments!

Vendor: nouveau (0x10de)

Nouveau has pretty bad OpenGL support last time I checked… If you can, you should use a the vendors driver (Intel, AMD, NVidia) driver for decent OpenGL support!

I run Fedora 30 at home, so should be able to double check for you. Sorry - Ubuntu at work.
As I remember I had to install a boat load of X libraries at one point. Fedora uses this new fangled Wayland thing.
I have onboard Intel graphics on my laptop - I have no idea which driver I am using (what a sad thing to say),

I think I found the proper driver. I will follow this path …