Gadfly for Julia version 1.1.1

Is Gadfly be available for Julia version 1.1.1? I have tried various ways of adding it (including pkg"add Gadfly#master", Pkg.clone(“Gadfly”), pkg"dev Gadfly") without success. With the master copy, I receive an error stating that there are “unsatisfiable requirements for package kernel density”.

Many thanks

This likely isn’t an issue with Gadfly. The tagged version works fine on 1.1.1.

The unsatisfiable requirements may come from some pinned packages that you have. Unfortunately the package manager still doesn’t give the most helpful error messages in those scenarios.

Could you provide the full error you are seeing?

does it work if you install it in a clean environment? so ]activate test; dev Gadfly. if so, then do a ]st to get a list of package versions and compare with the versions in your default environment to look for conflicts.

Thanks to you both for your advice. The error messages were variable and I couldn’t wrap my head around the version conflicts so I eventually decided to re-install Julia, making sure to add the Gadfly package prior to any others. All is working as expected now. Cheers!