Flux precompilation takes way too long (1.6.1)

I am not able to use Flux (Linux 64 bits, Julia 1.6.1). Precompilation takes forever. Killing it and using it in a new section goes down the same road and precompilation never ends. I do not get any error message, though.

Any idea of what may be going on?

(@v1.6) pkg> st
      Status `~/.julia/environments/v1.6/Project.toml`
  [6e4b80f9] BenchmarkTools v0.7.0
  [336ed68f] CSV v0.8.4
  [b630d9fa] CheapThreads v0.2.3
  [46823bd8] Chemfiles v0.9.3
  [35d6a980] ColorSchemes v3.12.0
  [6f35c628] ComplexMixtures v0.4.16
  [a93c6f00] DataFrames v1.0.1
  [b4f34e82] Distances v0.10.2
  [e30172f5] Documenter v0.26.3
  [35a29f4d] DocumenterTools v0.1.10
  [fde71243] EasyFit v0.5.4
  [7a1cc6ca] FFTW v1.4.0
  [cc61a311] FLoops v0.1.10
  [587475ba] Flux v0.12.3
  [59287772] Formatting v0.4.2
  [c58ffaec] FortranFiles v0.6.0
  [28b8d3ca] GR v0.57.4
  [4c0ca9eb] Gtk v1.1.7
  [f67ccb44] HDF5 v0.15.4
  [cd3eb016] HTTP v0.9.0
  [7073ff75] IJulia v1.23.2
  [18364772] IPython v0.5.0
  [916415d5] Images v0.24.1
  [0f8b85d8] JSON3 v1.8.1
  [b964fa9f] LaTeXStrings v1.2.1
  [23fbe1c1] Latexify v0.15.5
  [bdcacae8] LoopVectorization v0.12.12
  [33e6dc65] MKL v0.4.0
  [6741aa20] Neptune v0.14.0
  [6fd5a793] Octavian v0.2.13
  [6fe1bfb0] OffsetArrays v1.7.0
  [429524aa] Optim v1.3.0
  [e29189f1] PDBTools v0.12.9
  [8314cec4] PGFPlotsX v1.2.10
  [d96e819e] Parameters v0.12.2
  [91a5bcdd] Plots v1.12.0
  [c3e4b0f8] Pluto v0.14.3
  [7f904dfe] PlutoUI v0.7.1
  [08abe8d2] PrettyTables v1.0.0
  [92933f4c] ProgressMeter v1.5.0
  [d330b81b] PyPlot v2.9.0
  [1fd47b50] QuadGK v2.4.1
  [295af30f] Revise v3.1.15
  [efcf1570] Setfield v0.7.0
  [f62ebe17] ShortCodes v0.3.2
  [aa65fe97] SnoopCompile v2.6.0
  [e2b509da] SnoopCompileCore v2.5.2
  [860ef19b] StableRNGs v1.0.0
  [90137ffa] StaticArrays v1.1.1
  [2913bbd2] StatsBase v0.33.7
  [09ab397b] StructArrays v0.5.1
  [856f2bd8] StructTypes v1.7.2
  [0c5d862f] Symbolics v0.1.24
  [b189fb0b] ThreadPools v1.2.1
  [ac1d9e8a] ThreadsX v0.1.7
  [a759f4b9] TimerOutputs v0.5.8
  [bc48ee85] Tullio v0.2.14
  [1986cc42] Unitful v1.7.0
  [45397f5d] UnitfulLatexify v1.5.1
  [42071c24] UnitfulRecipes v1.2.0
  [33b4df10] VectorizedRNG v0.2.8
  [9fa8497b] Future
  [de0858da] Printf

Now (not before), when I tried to use it, it started to download CUDA, and this is taking a lot of time (less than 1% per minute):

julia> using Flux
[ Info: Precompiling Flux [587475ba-b771-5e3f-ad9e-33799f191a9c]
 Downloading artifact: CUDA
    Downloading [======>                                  ]  13.4 %

My connection is not bad. How large is that? Or there is another problem?

Also, is that what is possibly slowing down the precompilation when I first added it (without the download being shown?)

Might be this issue:


1 Like

I got curious: what are the artifacts? They occupy 9GB in my .julia directory.

(I have only some more 15Gb free space here in my SSD, so that starts to make a difference).

artifacts are compiled binaries that libraries pull in. They typically occur from libraries that use C packages (like, say Arpack).

1 Like


1 Like

thanks, though after that CUDA install I have 3GB more :grimacing:

probably I will have to restart over at some point

It appears that the problem was the silent download of CUDA drivers. It finally finished (~2 hours) and it worked. The developers are aware of the issue, I don’t know why this download takes so much.

1 Like

Just an important update. The issue was the download of the CUDA drivers while precompiling, associated to the fact that the access to Julia servers from here (Brazil) was very slow. But now a server in São Paulo was established and everything is much, much faster here. That is an important improvement on the user experience in general for people here in Brazil.