FemtoCleaner in 1.x (or even 0.6)

FemtoCleaner.jl isn’t registered, nor would install, so I tried to install it in Julia 0.6 that it’s made for. I wanted to migrate some Julia 0.6 code, and believe it’s for that (the only such tool?):

julia> Pkg.add("https://github.com/JuliaComputing/FemtoCleaner.jl")
INFO: Initializing package repository /home/pharaldsson/.julia/v0.6
INFO: Cloning METADATA from https://github.com/JuliaLang/METADATA.jl
ERROR: GitError(Code:ERROR, Class:Net, curl error: Could not resolve host: github.com

I got the same error with https, thought it might be the problem, so changed to http, but as can be seen didn’t work, got somehow changed back.

I’m trying to put myself in the shoes of users that need to convert some code (fortunately increasingly rare).

How to convert (but I want to use tools):

FYI, the code:

I could figure it out, or someone can offer help (already did, linking to original prior to my edit there), the code is short and sweet except it no longer works (except for 0.6, that juliaup supports).

[The code in Rosetta (until I get it updated…) gives silent wrong results in 1.x.]

This is my first (shorter) version that works in old and new versions, and actually collect is redundant:

for t in ("A", "ö", "Ж", "€", "𝄞")
  println(t, " → ", collect(codeunits(t)))

Older version: This is my shorter version which at least errors (and works in 0.6), would like to know how/if the tool works with the original or any version:

for t in ("A", "ö", "Ж", "€", "𝄞")
  println(t, " → ", convert(Vector{UInt8}, t))