Feedback on inconsistent naming of types for Julia v1.0 release

This thread is an attempt to collect names in the language that don’t seem to be consistent from a user’s perspective. It would be nice to have them revisited for consistency?

Today I came across DArray for distributed arrays versus SharedArray for shared arrays. I see that packages like StaticArrays have adopted short names as well like SArray and MArray for statically-sized arrays. What do you think of ShArray for the shared array case? Keep it short?

Distributed arrays and shared arrays are now in the standard library, so their names can be changed after 1.0.


Wait, things in the standard library can be broken during julia 1.x? Really? That seems a terrible idea… I thought 1.0 meant that everything that ships with the binaries you get from will not break existing code in any 1.x release?

1 Like

ShArray is less desirable than SharedArray imo, ShArray does not mean anything to me (should we be very quiet when using that sort of array – no, that’s ShhArray).


Perhaps make it more verbose everywhere then? Like DistributedArray and SharedArray? I sympathize with the concern. What I am trying to point out is the inconsistency. I like the idea of having very explicit names.

More generally, there had been an authoritative message regarding Julia favoring clarity, obviousness in naming things (@StefanKarpinski may have written that on behalf of all).

1 Like

Standard library packages will be versioned like other packages, which means you can lock their version and still upgrade Julia itself, which won’t break since it has API stability.